Go Back  F150online Forums > F-Series Trucks > 2004 - 2008 F-150
'04 owners how's your truck holding up? >

'04 owners how's your truck holding up?

2004 - 2008 F-150

'04 owners how's your truck holding up?

 
  #106  
Old 08-25-2007, 08:55 PM
Senior Member
Thread Starter
Join Date: Sep 2004
Location: Winnipeg, Manitoba
Posts: 3,119
Likes: 0
Received 0 Likes on 0 Posts
One common thing I keep reading is about the rear sliders crapping out. Glad I went with the solid rear window!
 
  #107  
Old 08-25-2007, 08:59 PM
Senior Member
Thread Starter
Join Date: Sep 2004
Location: Winnipeg, Manitoba
Posts: 3,119
Likes: 0
Received 0 Likes on 0 Posts
Originally Posted by xaudio62
I bought it used and it didn't come with an owners manual. How do I find out things like what gears are in the truck?
Check on the drivers side door pillar, you'll find all the codes there. You can also check the tag on the diff (if it's still there). That will tell you gear ratio and ring gear size.
 
  #108  
Old 08-25-2007, 09:51 PM
Senior Member
Join Date: Sep 2003
Posts: 599
Likes: 0
Received 0 Likes on 0 Posts
Originally Posted by Texan Aviator
'04 F150 SCREW
50k miles
Battery went out about 6months ago.
Rear automatic sliding window stopped sliding, need to get er fixed. That's all though. Great truck!
Yea, I'm still on the stock battery. I should probably head to Sears now and put a new one in. Winter's right around the corner...
 
  #109  
Old 08-25-2007, 10:31 PM
Senior Member
Join Date: Nov 2006
Posts: 625
Likes: 0
Received 0 Likes on 0 Posts
Originally Posted by BHibbs
Yea, I'm still on the stock battery. I should probably head to Sears now and put a new one in. Winter's right around the corner...
I'd highly suggest it. Mine went without warning.... Just out of the blue wouldn't start, no clicking no nothing just the flashing of a few dash lights, then nothing. Luckily I was at home!
 
  #110  
Old 08-25-2007, 11:28 PM
Senior Member
Join Date: Jul 2005
Posts: 237
Likes: 0
Received 0 Likes on 0 Posts
My 04 XLT with 64K has the airbag light on now. Just another issue to add to the list of probs I've experienced already.
 
  #111  
Old 08-26-2007, 08:59 AM
Senior Member
Thread Starter
Join Date: Sep 2004
Location: Winnipeg, Manitoba
Posts: 3,119
Likes: 0
Received 0 Likes on 0 Posts
Originally Posted by xlint1
My 04 XLT with 64K has the airbag light on now. Just another issue to add to the list of probs I've experienced already.
Which light is on? If it's the one over the radio it could mean a problem with the harness in the passenger seat. The light on the instrument panel is telling you that there's a problem in the airbag system that needs to be corrected.
 
  #112  
Old 08-26-2007, 01:25 PM
PawPaw's Avatar
Senior Member
Join Date: Feb 2007
Location: Lockport, La.
Posts: 4,504
Received 1 Like on 1 Post
Had to get rear end replaced at 11k miles, rear sliding motor replaced once and it's not working now. Driver's side window fell down once. All these problem's fixed in warranty. My previous truck was a 2000 Super Duty that I had for about 4 yrs. and never had any problems with it other than a real rough ride. My F-150 does have a lot smoother ride!
 
  #113  
Old 08-27-2007, 10:12 PM
Senior Member
Join Date: Mar 2007
Location: Ames, IA
Posts: 127
Likes: 0
Received 0 Likes on 0 Posts
I got a 2004 XL 2wd that has 78,xxx on it and it runs like a charm. No rattles or squeaks. Runs like brand new. She will be with me till I am out of college.

Zane
 
  #114  
Old 08-28-2007, 08:51 AM
Senior Member
Join Date: Jul 2002
Location: Westland, Mi
Posts: 683
Likes: 0
Received 0 Likes on 0 Posts
2004 F150 Longbed with 76k miles

-reverse sensor went bad @37kmiles
-parking brake stuck on @40kmiles
-spark plug nightmare @60kmiles
-both rear axle seals went @ 75kmiles

-ii
 
  #115  
Old 08-28-2007, 12:29 PM
Junior Member
Join Date: May 2005
Posts: 4
Likes: 0
Received 0 Likes on 0 Posts
I got all you beat!

I have an '04 SCREW Lariat with 117,500 miles.

I have had a whole host of problems, with the big ones being:

-Transmission Rebuild @ 65k miles

-Rear End Rebuild @ 100k miles (2k miles shy of extended warranty expiration)

-Third Brake Light Leak (Dealer didn't see it as a problem, even though my truck smelled like someone "with too much sour cream on the taco"; so I just siliconed the whole damn thing to my truck - this fixed the problem, but will be a problem again when the light burns out)

-Rattles and Squeaks all over the place

I still love this truck, but wouldn't mind selling it for something new, because the tranny is about to die again - and I don't want to shell out over $2500 again. Oh well, I guess I can't complain until it happens.
 
  #116  
Old 08-30-2007, 02:27 PM
Member
Join Date: Dec 2004
Posts: 16
Likes: 0
Received 0 Likes on 0 Posts
I bpught my '04 new late in 2005. build date was early 05. I bought the 100,000 mile warranty w' no deductable.
I have right over 50,000 miles now.
No issues other than standard maintenance.
I did have the battery die without warning in the middle of nowhere at around 43,000 miles. I did the brakes at about 40,000.
I have yet to have any recalls done. sounds like i need to take it in and have the butyl pad done. I never got a notice on this, or any recalls, should I have? I also have the rear window. I have noticed a rattle in the last year. It's on my list to get done. I have never noticed a leak in the truck but the third brake light does get condisation occasionally.
 
  #117  
Old 08-30-2007, 08:25 PM
Senior Member
Join Date: Sep 2006
Posts: 1,064
Likes: 0
Received 0 Likes on 0 Posts
Originally Posted by LUVMYSCREW
I bpught my '04 new late in 2005. build date was early 05. I bought the 100,000 mile warranty w' no deductable.
I have right over 50,000 miles now.
No issues other than standard maintenance.
I did have the battery die without warning in the middle of nowhere at around 43,000 miles. I did the brakes at about 40,000.
I have yet to have any recalls done. sounds like i need to take it in and have the butyl pad done. I never got a notice on this, or any recalls, should I have? I also have the rear window. I have noticed a rattle in the last year. It's on my list to get done. I have never noticed a leak in the truck but the third brake light does get condisation occasionally.
If your build date is early 05 then it is an 05 becuase I have an 05 and my build date is 11/04
 
  #118  
Old 12-19-2007, 11:53 AM
Junior Member
Join Date: Nov 2007
Location: Mississippi
Posts: 3
Likes: 0
Received 0 Likes on 0 Posts
04 SCREW FX4 4X4 with 146,000 miles. Only in shop twice: COP's both times. Now it bogs down when you press on the accelarator. Other than those problems it has been a good truck. Still looks like new.
 
  #119  
Old 12-19-2007, 01:55 PM
Senior Member
Join Date: Nov 2003
Location: Yucaipa, California
Posts: 446
Likes: 0
Received 0 Likes on 0 Posts
Originally Posted by HamRadio
37,000 mile on my 04 150. 20,000 of that towing a travel trailer at 6500#.
I've done the regular maintenance. Replaced spark plugs at 26k and 36K. The last replacement to a cooler range plug. Replace fuel filter early on. Just replaced the "ice cube tray" plastic covers in front of the windshield. They were starting to rot and crack.

I did a flush, filter and tranny fluid replacement last week. I run an additional tranny cooler with a fan in addition to the stock cooler. The original fluid was nice and bright red. Could not tell the difference between it and the new fluid.

I had a leak in the third brake lite too. Got that fixed two years ago. Took it in to the dealer for the TSB on front brake shudder. They fixed that one ok. Had a dealer re-flash for the throttle lag (but Troyer fixed that too). I reflash on a regular basis. I go from a tow tune to my performance tune a lot. No issues here. Planing a 4K trip next month with my TT. I really enjoy towing with this truck.

When I retire in about 1 1/2 years from now I think we will keep the 150 for mama and I will go to a 250 diesel.
Now its a few months past my previous post. We put on 4200 miles from Southern California to Oregon, Washington and Northern Idaho pulling my TT with a weight of 6800 lbs. Got a good chance to get it on a scale in Oregon with a full load after weighing the 150 empty. We did about 500 of those miles without the TT. Overall I got 13.3 Mpg. Empty the 150 gets me 16 on the road. All systems went well. After getting home for a month with a total of 45,000 miles on the od I had to do a brake job which included the front rotors. I really can't complain as much of that mileage is towing. I did tow with Mike's Tow/Performance tune running 91 octane and sometimes higher up north.

One day a few weeks ago on the way home from work, almost in my driveway, the engine went into failsafe. I pulled the codes with my scangauge and it pointed to the throttle position sensor. I pulled the throttle body per the shop manual. I also ordered a new sensor on-line that night and had it the next evening. Replaced the sensor and it not only fixed the problem but the throttle seemed to work even better than ever. One point here is to remove the old sensor exactically as the directions state. The screws that hold the sensor to the throttle body have anti-sieze on them from the factory. You need to have a power driver to remove them and do it FAST! Otherwise they will sieze and break off in the throttle body. Do NOT try and take the screws (three of them) out by hand! You WILL loose.


So for now I am a happy camper. I see some of you have had tranny problems. I do kinda worry about that in the future and have added a second fan assisted cooler (at 15K miles) and monitor my temps inside the tranny and cooler return temps. So when I'm towing I know how hard its working. Never had to stop to cool off so far.
 

Last edited by HamRadio; 12-19-2007 at 02:09 PM.
  #120  
Old 12-19-2007, 03:00 PM
Senior Member
Join Date: Oct 2004
Location: British Columbia
Posts: 860
Likes: 0
Received 0 Likes on 0 Posts
Mine was one of the first off the Kansas City assembly line, built in September of '03. Now has 77000 km on it. Never had a single issue with it other than changing to the new rotors. I just noticed the 3rd brakelight is burned out. I guess the first few off the line were the best. Either that or it was built on a Monday.
 

Thread Tools
Search this Thread
Quick Reply: '04 owners how's your truck holding up?


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: