Fuse 6 keeps blowing - F150online Forums

Go Back  F150online Forums > Body > Electrical Systems
Fuse 6 keeps blowing >

Fuse 6 keeps blowing

Fuse 6 keeps blowing

  #1  
Old 09-14-2018, 05:50 PM
Junior Member
Thread Starter
Join Date: Sep 2018
Posts: 4
Fuse 6 keeps blowing

Hello, fuse 6 on my 08 f150 keeps blowing when I turn the parking lights on which led me to believe it was an issue with the headlight switch and after replacing the switch the problem persists, I'm not sure what else it could be. The fuse controls parking lights, body security module, and instrument panel illumination. The truck also has LED headlights, taillights, and fog lights.

any help is greatly appreciated.

 
  #2  
Old 09-14-2018, 09:12 PM
Senior Member
Join Date: Sep 2007
Location: The Barbary Coast
Posts: 3,313
Every light on my '07 has been upgraded to LED. That should not be a problem. Unless one of your lights is actually causing the fuse to blow. Pull the lights out and check them. Switch them all back to OEM spec halogen. Knowing that LED actually draw less electricity, OEM spec halogen will draw more electricity. Almost seems counter-intuitive. Did you splice any wiring or install diodes or load resistors? DIY wire splicing, if not done well, could lead to poor connections, bad grounding, arc faults, ground faults, et cetera.
 
  #3  
Old 09-14-2018, 09:26 PM
Junior Member
Thread Starter
Join Date: Sep 2018
Posts: 4
Fifty150, unfortunately all the lights were installed when I bought it but it does have load resistors for the blinkers and all the splicing and the rest of the wiring looks good as far as I can tell. So I'd imagine that's not the problem if you like I could nab pictures of everything when I get home/tomorrow maybe theres something I'm missing. If it helps at all, all the lights worked fine (except the side markers on both sides were flickering) until I got home last night then the instrument panel just went dark.
 

Last edited by link34210; 09-14-2018 at 09:30 PM.
  #4  
Old 09-15-2018, 01:36 AM
Junior Member
Thread Starter
Join Date: Sep 2018
Posts: 4
Hey I figured it out it!! Someone put aluminum foil between the bulb and the harness for it o.o the side markers still flicker though hmm
 
  #5  
Old 09-15-2018, 06:52 PM
Senior Member
Join Date: Sep 2007
Location: The Barbary Coast
Posts: 3,313
Foil?
 
  #6  
Old 09-15-2018, 06:55 PM
Junior Member
Thread Starter
Join Date: Sep 2018
Posts: 4
Yeah foil wrapped around the conection on the bulb.
 
  #7  
Old 09-16-2018, 03:57 AM
Patman's Avatar
Global Moderator &
Senior Member

Join Date: Aug 2005
Location: DFW
Posts: 20,679
wow thats bazaar. Good find!
 
  #8  
Old 09-17-2018, 01:58 AM
Senior Member
Join Date: Sep 2007
Location: The Barbary Coast
Posts: 3,313
What kind of an idiot would do something like that?

But then again, I've seen a lot of stupid things in my lifetime. I'm not that old, either. Just readying myself to see even more stupid things.
 


Thread Tools
Search this Thread
Quick Reply: Fuse 6 keeps blowing


Sponsors

Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: