97 Expedition 5.4 Starts then dies - F150online Forums

Go Back   F150online Forums > Powertrain & Mechanical > V8 Engines
Log In 

97 Expedition 5.4 Starts then dies

Thread Tools Search this Thread
Old 09-25-2006, 10:29 PM
Junior Member
Join Date: Feb 2002
Location: Sacramento
Vehicle: 1997 ford F-150 4X4
Posts: 2
97 Expedition 5.4 Starts then dies

I have a 97 Expediton with the 5.4 with 126k miles. For the past couple of weeks I have been having problems with it starting in the morning. It starts, then dies. This happens a fews times but eventually I can get it running. The theft light flashes rapidly when this happens. Once it has started, it runs great. My husband replaced the IAC yesterday and it did the same thing this morning, started and died. Any suggestions as to what to do now???

Reply With Quote
Old 09-25-2006, 11:49 PM
Senior Member
Join Date: Mar 2005
Location: St. Charles, MO
Vehicle: 2000 Ford F-250 7.3
Posts: 5,843
My truck did this the first winter I got it...you'd start it in the morning and it'd die immediately. The only way to keep it running was to give it gas, and it'd eventually go on it's own. I ran a bottle of fuel injector cleaner through it, and haven't had it happen in almost 2 years.

Originally Posted by RockPick View Post
Having fun as a kid is one thing... being an absolute toolbox is another. You're the latter of that comparison.
In Hoc Signo Vinces
Reply With Quote
Old 09-26-2006, 12:00 AM
Bluejay's Avatar
Global Moderator &
Senior Member
Join Date: Mar 2005
Location: Burleson/Athens/Brownsboro, TX
Vehicle: 2014 Ford F150, 5.0
Posts: 24,282
If it has not been changed recently, change fuel filter.
Reply With Quote
Old 09-26-2006, 01:15 AM
Senior Member
Join Date: Apr 2003
Location: mn
Vehicle: 1997 Ford Expedition
Posts: 473
The theft light flashing seems to indicate a problem with the key or the ignition switch. If you had had a new key made at the hardware store that didn't have a chip in it then the truck would start then die then would not start again with that key. Maybe your key was damaged and the chip isn't getting read correctly by the ignition switch.
1997 Expedition 5.4, tow package, 265/75-R16, Firestone rear air bags, Amsoil, Banks Trans-Command
Reply With Quote


Similar Threads
Thread Thread Starter Forum Replies Last Post
Expedition Lost Coast - Sept 19-20 m3dragon West 2 10-23-2015 12:41 AM
Stopped shifting normally delu Transmissions 3 07-27-2015 06:20 PM
5.4 helicoil blewout Ghemp V8 Engines 5 07-17-2015 09:29 AM
F150 engine swap and 2wd conversion questions tsteve25 1997 - 2003 F-150 4 07-15-2015 09:52 AM
F150 4.6 5.4 swap Kman52 1997 - 2003 F-150 2 07-08-2015 01:23 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off

All times are GMT -4. The time now is 01:47 PM.

This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Fordé is a registered trademark of the Ford Motor Company