Go Back   F150online Forums > Powertrain & Mechanical > V8 Engines
Sign in using an external account
Register Forgot Password?
Register Photos Vin Decoder FAQ Members Search Today's Posts Mark Forums Read Vendor DirectoryGarage

Welcome to F150Online Forums!
Welcome to F150Online.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the F150Online Forums community today!





Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
  #1  
Old 10-17-2003, 03:24 PM
Junior Member
Garage is empty, add now
 
Join Date: Mar 2000
Location: Augusta, GA
Vehicle: 1997 Ford F150
Posts: 7
Question Where and how to change oil sending unit

I have a 97 XLT 4x4 with the 4.6 and about 62K on it and I'm still having oil pressure fluctuation on the gauge. A few people have segested changing the oil sending unit, but I'm not sure where it is and how diffecult it is to change. Any help would truly be appreciated!!!
Reply With Quote
  #2  
Old 10-17-2003, 03:45 PM
Senior Member
Garage is empty, add now
 
Join Date: Mar 2001
Location: Seabrook,NH
Vehicle: 2009 Ford Flex
Posts: 3,278
On my 5.4 it is right next to the oil filter. It just screws into the side of the filter mount. I am not sure about 4.6 engines.
__________________
09 Ford Flex Limited AWD
Reply With Quote
  #3  
Old 10-17-2003, 10:22 PM
Senior Member
Garage is empty, add now
 
Join Date: Mar 2001
Location: Indianapolis, IN, USA
Vehicle: 2003 Ford F150
Posts: 388
T-Connector after installing mine

Take a look at the link and/or the oil pressure gauge in my sig. That is where the sending unit is on my 4.2. It sounds like they are all in about the same place.
__________________
1993 Flareside XLT, regular cab, rebuilt 4.9, 2WD, E4OD.

2003 XLT, daily driver, 5.4L, AT, fiberglass tonneau cover, backup camera.
Reply With Quote
  #4  
Old 10-20-2003, 10:13 AM
Junior Member
Garage is empty, add now
 
Join Date: Mar 2000
Location: Augusta, GA
Vehicle: 1997 Ford F150
Posts: 7
Still not clear on where the oil sending unit is or how hard it is to change. I found some kind of sensor on the forward side of where the oil filter is located. Is this it?
Thanks again for any help!!!!
Reply With Quote
  #5  
Old 10-21-2003, 09:19 AM
Senior Member
Garage is empty, add now
 
Join Date: Jul 1999
Location: Milwaukee, Wisconsin
Vehicle: 1999 Ford F150
Posts: 466
That's it. Check to make sure the wires are making good connection first. Mine came loose and was reading erratic on the guage.
Reply With Quote
Old 10-21-2003, 09:19 AM


 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


All times are GMT -4. The time now is 03:42 PM.


 
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company
Contact Us Advertising Privacy Statement Terms of Service Jobs Forum Text Archives
Emails & Contact Details

Search Engine Friendly URLs by vBSEO 3.5.2