5.4 3v fuel issue - F150online Forums

5.4 3v fuel issue

  #1  
Old 10-10-2018, 02:19 PM
Junior Member
Thread Starter
Join Date: Oct 2018
Location: Ohio
Posts: 2
5.4 3v fuel issue

I've got a 07 f250 with the infamous 5.4 3v 217k my issue is running at idle or on a flat surface with little acceleration it runs good with 40 psi of fuel put it under a load or climb a hill after it warms up and it drops depending on throttle position at wot it drops to 3-5 psi and misses new parts include plugs, coils, injectors, fps, fpdm, fuel filter now I'm out of ideas I even pulled the cats with no change now if I throw it in neutral shut it off wait a second and restart it'll run good again for a few minutes I'm assuming something's getting hot and pulling my fuel pressure but what could it be is my question
 
  #2  
Old 10-10-2018, 02:43 PM
glc's Avatar
glc
glc is offline
Senior Member
Join Date: Dec 2006
Location: Joplin MO
Posts: 37,391
If you didn't use a Motorcraft FPDM, it could be defective. I'd also suspect the fuel pump itself. There's a sock type filter on the pickup in the tank that could be getting clogged.
 
  #3  
Old 10-10-2018, 03:29 PM
Junior Member
Thread Starter
Join Date: Oct 2018
Location: Ohio
Posts: 2
I was actually thinking that next pull the pump check the filter i guess it could be pulling debris and dropping pressure then when you cycle the key off and the pump stops running it drops whatever it's picking up
 


Thread Tools
Search this Thread
Quick Reply: 5.4 3v fuel issue


Sponsors

Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: