2004 - 2008 F-150

1714 problems

 
  #1  
Old 03-02-2005, 12:43 AM
Member
Thread Starter
Join Date: Nov 2003
Location: riverside ca.
Posts: 91
Likes: 0
Received 0 Likes on 0 Posts
1714 problems

truck started running like crap, missing, tranny felt like it was slipping, etc. little engine light and wrench light were both on. about s*** my pants. took the tune off[hi perf] and returned to stock, ran fine. put tune backon [87 oct.] ran fine for awhile then started missing again. just wrench light on this time. went to stock and its fine. any ideas? no reflash unless they didn't tell me about it. ask troyers? help!! stock sucks!!
 
  #2  
Old 03-02-2005, 12:54 AM
Senior Member
Join Date: Dec 2004
Location: Long Island, New York
Posts: 573
Likes: 0
Received 0 Likes on 0 Posts
Call Troyer (if that is where you ordered it from). If they can't help, call Superchips direct.
Good Luck!
 
  #3  
Old 03-02-2005, 01:00 AM
Member
Thread Starter
Join Date: Nov 2003
Location: riverside ca.
Posts: 91
Likes: 0
Received 0 Likes on 0 Posts
thats what I figered. I do want the xcalibrator so maybe they hook me up with the trade in. otherwise who wants a 1714?
 

Thread Tools
Search this Thread
Quick Reply: 1714 problems


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: