Go Back   F150online Forums > Powertrain & Mechanical > V8 Engines
Sign in using an external account
Register Forgot Password?
Register Photos Vin Decoder FAQ Members Search Today's Posts Mark Forums Read VendorsGarage




Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
  #1  
Old 12-28-2003, 02:24 PM
Junior Member
Garage is empty, add now
 
Join Date: Dec 2003
Location: Amanda,Ohio
Vehicle: 1993 Ford F150
Posts: 1
93 F150 5.0 engine miss under light load

My 93 F 150 5.0 with AOD has a miss in the engine under a light load,it appears to be alright was long as the engine is not pulling. I have tried new plugs,wires,fuel filter,distributor cap.rotor,and I took the brain off and had it checked at the parts store. Thre is no miss when shifting going from 1st to 2nd gear, but from then on the engine misses until you get into overdrive and the RPM's level off at a cruising speed.The engine will also miss in overdrive if pulling.DRIVING ME NUTS
__________________
don
Reply With Quote
Old 12-28-2003, 02:24 PM


 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



All times are GMT -4. The time now is 11:04 AM.


 
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company
Contact Us Advertising Privacy Statement Terms of Service Jobs Forum Text Archives
Emails & Contact Details

Search Engine Friendly URLs by vBSEO 3.5.2