Go Back   F150online Forums > F-Series Trucks > 1997 - 2003 F-150
Sign in using an external account
Register Forgot Password?


1997 - 2003 F-150 SPONSORED BY:

Welcome to F150Online Forums!
Welcome to F150Online.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the F150Online Forums community today!





Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
  #1  
Old 03-29-2011, 11:44 AM
Member
 
Join Date: Feb 2010
Posts: 30
P0303 cyl #3 misfire code driving me crazy

I have a obd2 P0303 cyl #3 misfire code ,changed plugs,changed wires ,swapped coil temporarily for one i know is good , this is on V-6 auto continuous check engine flashing- car runs fine drives good then irradic idle and will stall in gear. At other times it runs and idles smooth? changed IAC , still the same ,checked for vaccuum leaks can't find any?
Reply With Quote
  #2  
Old 03-29-2011, 12:27 PM
Technical Article Contributor
 
Join Date: Oct 2005
Location: MI
Vehicle: 1998 Ford F150 5.4L 4X4
Posts: 25,594
Flashing MIL means just one thing, - she's missing. Fuel first, then ignition. Change the Fuel filter lately ? What's the pump pressure reading?
__________________
Windsor Built 5.4L, E40D, Transgo kit, 9.75 Rear gear, Brembo rotors, Carquest Blue's, Bilstein's, Ported & Polished Intake/TB, Denso Iridium's, Pace setter LTH's, Magnaflow HFC's, Magnaflow 20X9X2.5 HF Muffler, Type 3 19lb Injectors, Volant Intake w/Amsoil EEA191 Filter, 265/17 GY Fortera's.

Compression Testing Procedure
Reply With Quote
  #3  
Old 03-29-2011, 04:23 PM
Member
 
Join Date: Mar 2011
Location: Low Country, South Carolina
Vehicle: 2000 Ford F150
Posts: 39
Mine did this too except im a 5.4L. When she is missing on one cyl the truck idles a little rough but will not stall. Once I changed the coil and plug she runs smooth but when i pull up to a stop light the idle will jump and fall and eventually the engine would die. This went on for a month or two until the coil fouled out again so i havent done anything to fix it yet. There is a grounding wire that screws into the fire wallthat let the water drain in and drip down on top of the COP that i have fixed with a lil silicone. I would rather it always run a lil run rough than cut off on me every time i stop so i havent replaced the COP.
Reply With Quote
  #4  
Old 03-30-2011, 12:40 PM
Member
 
Join Date: Feb 2010
Posts: 30
it has about 30psi on the fuel rail , could a single bad/clogged injector be causing the problems? is 30 psi enough or is there a fuel pump problem ? thank you in advance for any help
__________________
cwthill-:-craig hill central,Florida 97 f150 4.6L, 4r70w, 3:55ls,stock,cold air intake,pioneer 6 disc,285/mickey thompsons on rear

Last edited by cwthill; 03-30-2011 at 12:42 PM.
Reply With Quote
Old 03-30-2011, 12:40 PM


 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


All times are GMT -4. The time now is 05:40 PM.


 
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company
Contact Us Advertising Privacy Statement Terms of Service Jobs Forum Text Archives
Emails & Contact Details