F150online Forums - Search Results

Search: Posts Made By: khackr
Showing results 1 to 15 of 15
Search took 0.03 seconds.
Forum: V8 Engines
08-09-2010, 08:25 AM
Replies: 25
Views: 58,204
Posted By khackr

I understand- You might pull the left valve cover...

I understand- You might pull the left valve cover and see how clean the engine is- if dark and dingy I wouldnt waste me time- if clean and shiny - the oil has been changed regularly
and not beat too...
Forum: V8 Engines
07-26-2010, 11:35 PM
Replies: 25
Views: 58,204
Posted By khackr

Depending on what is wrong with your existing...

Depending on what is wrong with your existing one, and the milege, and how clean it is inside. I had 155K on the engine that came out, timing chain had jumped and dropped a valve through a piston....
07-26-2010, 11:26 PM
Replies: 23
Views: 46,791
Posted By khackr

I wound up moving the electrical sensors, oil pan...

I wound up moving the electrical sensors, oil pan due to oil sensor not being in the newer engine- intake, which has to come off anyway and 04 has some different vacuum setups- I used the newer...
Forum: V8 Engines
07-21-2010, 07:23 PM
Replies: 25
Views: 58,204
Posted By khackr

Tore apart the front of the engine saturday,...

Tore apart the front of the engine saturday, chain was off 2 teeth on bank 1. redid both chains, now runs Great! no more codes.
Thanks for all the help here.
07-21-2010, 07:22 PM
Replies: 23
Views: 46,791
Posted By khackr

Tore apart the front of the engine saturday,...

Tore apart the front of the engine saturday, chain was off 2 teeth on bank 1. redid both chains, now runs Great! no more codes.
Thanks for all the help here.
06-19-2010, 02:00 AM
Replies: 23
Views: 46,791
Posted By khackr

Did that- wondering if the cams are different?

Did that- wondering if the cams are different?
06-18-2010, 08:55 PM
Replies: 23
Views: 46,791
Posted By khackr

2008 to 2004 swap

I hope this thread isnt dead- same basic subject line. I put a 2008 expedition 5.4 with 46,500 into a 2004 5.4 truck and had trouble since. gets a P0340 code and wont run with the cam sensor plugged...
Forum: V8 Engines
06-14-2010, 09:35 PM
Replies: 25
Views: 58,204
Posted By khackr

"Start with basics" Thanks- I just dont look...

"Start with basics"
Thanks- I just dont look foward to tearing down the front of this thing- especially having to discharge the A/C to do it- but I think it is inevitable- I keep thinking it will...
Forum: V8 Engines
06-14-2010, 09:33 PM
Replies: 25
Views: 58,204
Posted By khackr

Let me know how that works for you- mine was from...

Let me know how that works for you- mine was from a 2008 expedition. I have another ford dealer trieng to help now.
Forum: V8 Engines
06-03-2010, 10:08 PM
Replies: 25
Views: 58,204
Posted By khackr

The odd thing is it will idle and run ok with the...

The odd thing is it will idle and run ok with the cam sensor unplugged- open loop mode I believe. Plug it in, surges and dies. Does this sound at all familiar?

Thanks
Forum: V8 Engines
06-01-2010, 11:37 PM
Replies: 25
Views: 58,204
Posted By khackr

Thanks for the replies This engine came from a...

Thanks for the replies
This engine came from a wrecked 2008 Expedition- 46k, clean internally- I just pulled the left cover and inspected the cam vct sprocket- center tab is lined up with the L. Is...
Forum: V8 Engines
05-31-2010, 03:57 AM
Replies: 25
Views: 58,204
Posted By khackr

I guess I should have gone a little farther on...

I guess I should have gone a little farther on the explanation- I have been fighting this for a month now. Changed Both sensors- changed crank sensor and VCT solenoids. had ford Reprogram the PCM, no...
Forum: V8 Engines
05-29-2010, 04:20 PM
Replies: 25
Views: 58,204
Posted By khackr

5.4 3V Chain Jumped? P0340

I Have a 2004 F150 with a 2008 5.4 3v, wont idle- P0340- after $400 at ford I stopped , they said likely plugged up journals- $1000 + to fix- I dont thik so. I think it is a timing chain off 1 tooth...
Forum: V8 Engines
05-29-2010, 01:12 PM
Replies: 126
Views: 9,662
Posted By khackr

5.4 3v timing jumped??

Have a 2004 F150 with a 2008 5.4 3v, wont idle- P0340- after $400 at ford I stopped , they said plugged up journals- $1000 + to fix- I dont thik so. I think it is a timing chain off 1 tooth on bank...
05-09-2010, 09:04 PM
Replies: 11
Views: 9,489
Posted By khackr

2008 expedition to 2004 f150 engine

I did the same thing and have not been able to make it run correctly, wont idle and
p0340 code. tested all wiring and sensors.

Did your changeover work?
Showing results 1 to 15 of 15


 
Forum Jump

Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.