F150online Forums - View Profile: Raptor05121

Go Back  F150online Forums > Members
Reload this Page >

Raptor05121's Profile

Raptor05121 Raptor05121 is offline

Technical Article Contributor

About Me

  • About Raptor05121
    Year
    1998
    Make
    Ford
    Model
    F-150
    Body
    Supercab
    Trim
    Base
    Color
    Oxford White
    Location
    Live Oak, FL
    Interests
    Flying, Fords, Mustangs, Mooneys
    Occupation
    911 Dispatcher
    Gender
    Male
  • Signature
    -Alex


    4.2L V6 - M5ODR2 ~420K miles | SCT XCal3 | K&N Series 77 | 16" Dual E-fans | Magnaflow Cats | 2" Drop Shackles
    Philips 85122XV C1 4800K / Matsu Gen5 Ballasts / FX-R 2.5" v2.1 | Philips LumiLED Taillights | Plasmaglow Fire & Ice

    Originally Posted by MGD
    No one Bends it Like Raptor

Statistics

Total Posts
Albums
Visitor Messages
Total Likes
General Information
  • Last Activity: 07-23-2017 11:12 PM
  • Join Date: 01-06-2007

Social Profiles

Instant Messaging
Send an Instant Message to Raptor05121 Using...
This Page
https://www.f150online.com/forums/members/108344-raptor05121.html

Friends

Showing Friends 1 to 10 of 32

Visitor Messages

Showing Visitor Messages 1 to 10 of 132
  1. 12-09-2014 12:25 AM
    Same old brother! It's been ages, how have you been?
  2. 10-10-2014 11:05 AM
    I'm afraid that's the only way to get it, I had actually forgotten they came that way.
  3. 10-07-2014 11:54 AM
    I'm afraid I won't be much help there, it's discontinued and I checked our obsolete supplier and the national parts locator and there's not a one in the country.

    Sorry.
  4. 07-13-2014 11:21 PM
    Are you still doing those LED taillight mods? I have a 13 XLT and I love the look of LED taillights, but the difference between running lights and brake lights makes me wary of them. Your retrofit seems to do away with that entirely. I was trying to view the pictures on your retrofit thread, but it seems all the photobucket files are moved/missing, making it hard to try and recreate it myself. Thanks in advance
  5. 06-22-2014 06:40 PM
    Haaa I see. I will locate and work on when I get the chance. Fixing to finish calculus soon. Thanks for the input, very appreciated
  6. 06-21-2014 12:04 PM
    How would I go about buying those things? Installing? Just to say, I have OEM heads that were scissored for this retro.
  7. 06-20-2014 04:59 PM
    Hey

    Quick question.
    I have redone my retrofit for the third time now, and have been able to greatly cut down on condensation, so to say this is the first time in about 5 months that I get any. Would one 1/2" hole on the back side of my headlight help with the evaporation of the condensation? Seals have been done and re-done and I don't know what to do anymore.

    Any input is appreciated
  8. 06-29-2013 12:19 AM
    Hey, I had a crappy HID kit, they were dimmer than my silverstar 9007's. I still have the stock headlights, and really like the Harley and Lightning headlights & corners better. I want a smooth, clear lens.
    I remember seeing your post on your HID's a few years back but had trouble finding it. They looked like they had a lot of light output, and that's what I am looking for, so I figured I'd ask.
    Most importantly I want more light output & was thinking about a 55W 4300K HID kit soon also.
    I can't seem to find anything that I like with the actual headlight assemblies though, I don't want "ricey", but I still would like projectors; they seem to do a better job IMO. I also wouldn't mind the angel eyes if they look good.
    Do you know of anyone who makes a decent headlight with projectors that are close to the Harley style I am looking for?
    You can email or text me if you want, I don't ever get on here... any input would be appreciated! [email protected] 843-338-1406
  9. 05-01-2013 01:29 PM
    Hi Raptor, I have an 06 f150 KR SCrew, and saw your post on your CB/PA install, but can't find the thread. Could you please post a link with it? and does it show how you installed it or just the finished product?
    Thanks!
  10. 01-10-2013 08:56 AM
    Hi Raptor,

    I'm new to the forum and joined because i'm having some trouble with my KC Aux Backup lights that I installed about a year ago. I hooked them up to my reverse lights using the relay that came with them. They worked fine for a little over a year, and then on New Years Eve a friend told me that my back up lights were on, although my truck was in park with the ignition off and the keys in my pocket. When I started my truck and put it in reverse, the lights would go off, but then back on when I put it in any other gear (P, N, D). I couldn't get them to turn off so I just unplugged the power. Now if I plug the same wire back in that I disconnected, they don't work at all... Any ideas? Maybe lost a ground? I don't know a whole lot about wiring so before I crawl under th truck (in the snow) I wanted to see if anyone could diagnose what might be wrong based on the series of events that took place.

    Thanks!

Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.