Go Back  F150online Forums > Body > Interior Care
Instrument cluster/speedo cover problems >

Instrument cluster/speedo cover problems

Instrument cluster/speedo cover problems

 
  #1  
Old 11-18-1999, 08:06 PM
Junior Member
Thread Starter
Join Date: Oct 1999
Location: Phoenix, AZ
Posts: 5
Likes: 0
Received 0 Likes on 0 Posts
Question Instrument cluster/speedo cover problems

Is anyone having problems with the plexiglass (???) instrument cluster/speedo cover. I seem to have a film of varying density throughout. I've tried various cleaners, including just plain soap/water. I can still see the instrument panel, but it's a pain that there appears to be some kind of a film on the plexiglass. And it appears to move around when you try to clean it off.

1997 F250 LD, SC, XLT
 
  #2  
Old 11-20-1999, 07:20 PM
Senior Member
Join Date: Apr 1999
Location: lindenhurst,ny,us
Posts: 220
Likes: 0
Received 0 Likes on 0 Posts
Red face

My truck has the same thing, but it appears to be a blotchiness- spiderweb behind the glass.

------------------
Gino Tedesco, '99 XLT 5.4l, SUPERCHIPPED, 3" Gibson catback exhaust,4x4 S/C Flareside D.wedge bl/Dk.graph, factory sidesteps & Tonneau cover, Manik grlgaurd w/Piaa lights, 305/70-16 Goodyear Wrangler AT/S tires


 
  #3  
Old 11-20-1999, 08:33 PM
Member
Join Date: Oct 1999
Location: Forest Lake, Mn.
Posts: 89
Likes: 0
Received 0 Likes on 0 Posts
Post

I've got the exact same thing. It's really getting annoying to look at. Somebody help!!

------------------
98' F-150, Off Road, Short Box, Blue, 4.6, K&N, Auto, Captain Chairs, Dual Exhaust
Alpine CD Player, (2) 10" Rockford Fosgate Subwoofers and a big ol' Arctic Cat
sticker on the rear sliding window!!!!! Soon to be chipped!!!
 
  #4  
Old 11-20-1999, 11:54 PM
Senior Member
Join Date: Jan 1999
Location: MO, USA
Posts: 923
Likes: 0
Received 0 Likes on 0 Posts
Post

Mine also has the blotchiness and dull look to it. I really didn't notice it until AFTER the warranty was up.
 
  #5  
Old 11-22-1999, 12:00 AM
Senior Member
Join Date: Jan 1999
Location: Chicagoland
Posts: 714
Likes: 0
Received 0 Likes on 0 Posts
Post

I have the same blotchy lens on the instrument cluster. A new lens costs less than $20.00. I'm going to change mine once I figure how to get the headlight switch out.
 
 


Thread Tools
Search this Thread
Quick Reply: Instrument cluster/speedo cover problems


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: