Help 2013 Platinum - Rear Defroster not working- Premium Care does't cover?n't cover? - F150online Forums

Go Back  F150online Forums > Body > Electrical Systems
Help 2013 Platinum - Rear Defroster not working- Premium Care does't cover?n't cover? >

Help 2013 Platinum - Rear Defroster not working- Premium Care does't cover?n't cover?

Help 2013 Platinum - Rear Defroster not working- Premium Care does't cover?n't cover?

  #1  
Old 10-11-2018, 12:45 AM
Junior Member
Thread Starter
Join Date: Mar 2015
Posts: 1
Thumbs down Help 2013 Platinum - Rear Defroster not working- Premium Care does't cover?n't cover?

Ford Service- Please help
Brought my truck into dealer on Staten Island for a defective rear defroster. The Premium Care brochure states "Heated back-glass electrical only. Not glass damage or breakage". So - is the defroster covered or isn't it? It seems that the problem is indeed electrical but apparently the whole window needs to be replaced to fix it! The dealer says the part number comes back as not covered. Seems silly that I have this extra warranty that says the defroster is covered but the only part that can be changed is not????
 
  #2  
Old 10-11-2018, 01:31 PM
Technical Article Contributor
Join Date: Jan 2007
Location: Vernon, NY
Posts: 7,963
Easy fix.... get a hammer, tappity, tap, tap until you hear a crack.

Call your local glass repair. They'll bill it right to your insurance.
 


Thread Tools
Search this Thread
Quick Reply: Help 2013 Platinum - Rear Defroster not working- Premium Care does't cover?n't cover?


Sponsors

Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: