Amp has power but no sound? - F150online Forums

Go Back  F150online Forums > Audio & Video System > Amplifiers
Amp has power but no sound? > Amp has power but no sound?

Amp has power but no sound?

Reply

 
 
  #1  
Old 01-25-2008, 11:32 AM
Senior Member
Thread Starter
Join Date: Nov 2006
Location: Minnesota
Posts: 249
Amp has power but no sound?

So I finally got by back seat off to mount my amps. I used a RF 2 amp install kit for my RFP4004 which runs my 4 speakers and a JL 250/1 for my stealth box. After hooking everything up the P4004 works great but the JL 250 is not pushing the sub? The power light is green and all my connections are good?
What steps should I take to make sure the amp is working properly?
 
Reply With Quote
  #2  
Old 01-25-2008, 11:44 AM
Senior Member
Join Date: Jun 2006
Location: San Diego
Posts: 327
Does your HU have seperate sub out? Can you disable it in the menu? Is it disabled?
 
Reply With Quote
  #3  
Old 01-25-2008, 11:51 AM
Senior Member
Thread Starter
Join Date: Nov 2006
Location: Minnesota
Posts: 249
I have the JVC HD01. It has separate sub rca out. I don't think it has a shut off for the sub, just an adjustment. I could be wrong but didnt see anything in the manual?
 
Reply With Quote
  #4  
Old 01-25-2008, 11:55 AM
Senior Member
Join Date: Jun 2006
Location: San Diego
Posts: 327
Hdr1?
 
Reply With Quote
  #5  
Old 01-25-2008, 11:56 AM
Senior Member
Thread Starter
Join Date: Nov 2006
Location: Minnesota
Posts: 249
Yes, my bad. JVC KD-HDR1
 
Reply With Quote
  #6  
Old 01-25-2008, 01:42 PM
Senior Member
Thread Starter
Join Date: Nov 2006
Location: Minnesota
Posts: 249
I just had BestBuy test my amp and it is dead
They had the Rockford Fosgate P400-2 on clearance for $140 so I grabbed one of those. Hooked it up and that JL Stealthbox POUNDS
 
Reply With Quote
  #7  
Old 01-25-2008, 01:44 PM
Senior Member
Join Date: Jun 2006
Location: San Diego
Posts: 327
glad you got it taken care of.
 
Reply With Quote
  #8  
Old 01-25-2008, 07:18 PM
Senior Member
Join Date: Jul 2006
Location: Freeport, Fl
Posts: 241
Originally Posted by jhogan20
I just had BestBuy test my amp and it is dead
They had the Rockford Fosgate P400-2 on clearance for $140 so I grabbed one of those. Hooked it up and that JL Stealthbox POUNDS
OOOOORRRRRRRR.....they just TOLD you it was dead so you would buy another one from them. Sounds to me like well-played big-box retail strategy.
 
Reply With Quote
  #9  
Old 01-26-2008, 01:07 AM
Senior Member
Join Date: Apr 2007
Location: Slidell, LA
Posts: 4,494
Originally Posted by Crewwzin
OOOOORRRRRRRR.....they just TOLD you it was dead so you would buy another one from them. Sounds to me like well-played big-box retail strategy.
Heyy now. Watch the Big Box comments. I have done that yes (once) but only because the dude was a Jack Ace (Im in vegas...)
 
Reply With Quote
  #10  
Old 01-26-2008, 11:10 AM
Senior Member
Thread Starter
Join Date: Nov 2006
Location: Minnesota
Posts: 249
He didn't try to sell me anything. The install guy was nice enough to test my amp on the spot at no charge. When he told me it wasn't working properly I left and found out they had a bunch of amps on clearance. I picked one up so I didn't have to wait another week or two to return my amp and wait for another one.
 
Reply With Quote
  #11  
Old 01-27-2008, 11:34 AM
Senior Member
Join Date: Jul 2006
Location: Freeport, Fl
Posts: 241
Originally Posted by Low_e_Red
Heyy now. Watch the Big Box comments. I have done that yes (once) but only because the dude was a Jack Ace (Im in vegas...)
Haha...not a personal stab, Low. This happened to a friend of mine one time who decided to be impatient. Not all the big box guys are as honest as they could be.
 
Reply With Quote
 
 
 

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Daltonkk
Speakers & Subwoofers
4
11-09-2015 11:52 AM
highfly24
Head Units
2
09-09-2015 01:36 AM
marcus1033
Speakers & Subwoofers
3
08-31-2015 01:42 PM
drtyjrzy
V8 Engines
1
08-22-2015 08:19 PM
aviduser
2009 - 2014 F-150
1
08-12-2015 01:07 AM

Thread Tools
Search this Thread
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Sponsors

All times are GMT -4. The time now is 04:40 PM.