Backfire/popping when i get on gas. - F150online Forums


2004 - 2008 F-150

Backfire/popping when i get on gas.

Reply
 
 
  #1  
Old 10-14-2010, 08:46 AM
Member
Thread Starter
 
Join Date: May 2010
Posts: 79
Backfire/popping when i get on gas.

Well its started a while ago but has became worse, when i return my truck to stock or the economy mode on my edge it will backfire/pop when i get on the gas or floor it. And not just once it does it pretty bad(almost like its insanely rich and its getting loaded up) but then clears out.

I'm not to sure on what it exactly could be. I have an edge evolution and when its on performance mode (3) it doesnt seem to do it.
two injectors and two coils have been recently replaced. My guess would be the rest of the coils...

Any suggestions would be greatly appreciated. thanks!

Last edited by Rebel-Offroad; 10-14-2010 at 09:01 AM.
Reply With Quote
  #2  
Old 10-14-2010, 01:06 PM
Senior Member
 
Join Date: Nov 2004
Location: Greenville, SC
Posts: 703
Any codes being thrown?
Reply With Quote
  #3  
Old 10-14-2010, 01:09 PM
Member
Thread Starter
 
Join Date: May 2010
Posts: 79
no codes except a catylist code last week, cleared it and it hasnt came back on since
Reply With Quote
  #4  
Old 10-14-2010, 01:16 PM
Senior Member
 
Join Date: Nov 2004
Location: Greenville, SC
Posts: 703
Sounds like an injector is sticking open, if even for just a split second. Stick around. Someone smarter than me will likely chime in soon. I would start with coils, plugs, and maybe even all the injectors, too.

Good luck, man!
Reply With Quote
  #5  
Old 10-14-2010, 01:33 PM
Senior Member
 
Join Date: Sep 2009
Posts: 107
Had the same problem and it ended up being plugs and wires
Reply With Quote
  #6  
Old 10-14-2010, 04:40 PM
Member
 
Join Date: Sep 2006
Location: Doylestown, Ohio
Posts: 90
Mine does the exact same thing. Its getting annoying, my truck has 72000mi guess its time to do the plugs and hope that fixes it.
Reply With Quote
  #7  
Old 10-14-2010, 05:25 PM
Technical Article Contributor
 
Join Date: Mar 2009
Location: Olive Branch, MS
Posts: 1,763
If it sounds like its coming from under your floor board then it's probably the cat. Mine did the exact same thing, popping at first acceleration shortly after it is started up and then it goes away if you let off the gas. Take it to the dealer and have them check it. They are under warranty till 80,000 if you are not over that yet.
Reply With Quote
  #8  
Old 10-14-2010, 06:45 PM
Member
 
Join Date: May 2010
Location: Athens, TN
Posts: 59
i just replaced all 8 injectors, now i am guessing plugs and cops
Reply With Quote
 
 
Reply

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
FarmGuy235
V8 Engines
6
07-10-2016 03:50 PM
Paltho
V8 Engines
0
09-16-2015 10:43 AM
Russell04fx4
V8 Engines
2
08-06-2015 09:45 AM
WAFORD
2004 - 2008 F-150
16
07-20-2015 04:58 PM
pa 150
2004 - 2008 F-150
6
07-19-2015 06:57 PM


Thread Tools
Search this Thread

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Sponsors

All times are GMT -4. The time now is 11:34 PM.