Engine bogging issue. - F150online Forums

Go Back  F150online Forums > F-Series Trucks > 1997 - 2003 F-150
Engine bogging issue. > Engine bogging issue.
Notices
1997 - 2003 F-150

Engine bogging issue.

Reply

 
 
 
  #1  
Old 05-15-2018, 09:54 PM
Joe Kearce's Avatar
Junior Member
Thread Starter
Join Date: May 2018
Posts: 3
Engine bogging issue.

This question may have been answered in previous threads, but I literally just joined and am having an issue.
I can be riding along in my 02 F150 5.4L 44 with no issues, accelerates fine. I bury the throttle to pass and engine bogs out. Back out the pedal, things level out, and I can press down enough for passing gear to kick in and make the pass if room/traffic allows.
In the last 6 months I have replaced air filter, MAF sensor, both upstream 02 sensors. Had PO171 and 174 codes for a while, but new MAF fixed that issue.
Have heard running lean for a while will destroy plugs....any truth. Any help will be helpful
 
Reply With Quote
  #2  
Old 05-16-2018, 09:11 AM
Senior Member
Join Date: Jan 2002
Location: Wilmington,NC
Posts: 4,100
Have you checked the fuel pressure?
 
Reply With Quote
  #3  
Old 05-16-2018, 10:05 AM
Joe Kearce's Avatar
Junior Member
Thread Starter
Join Date: May 2018
Posts: 3
Not yet. Was looking for ideas or suggestions to sorta guide in the direction.
 
Reply With Quote
  #4  
Old 05-16-2018, 11:34 PM
glc's Avatar
glc
glc is offline
Senior Member
Join Date: Dec 2006
Location: Joplin MO
Posts: 36,593
Pull the plugs and look at them. Change the fuel filter and test the fuel pressure.
 
Reply With Quote
  #5  
Old 05-17-2018, 12:17 AM
Joe Kearce's Avatar
Junior Member
Thread Starter
Join Date: May 2018
Posts: 3
What spark plugs do y'all suggest I run? I know Motorcraft is the brand, just looking for something other than plain old platinum
 
Reply With Quote
  #6  
Old 05-17-2018, 01:21 PM
Technical Article Contributor
Join Date: Jan 2007
Location: Vernon, NY
Posts: 7,128
Why? Just use the Motorcrafts.
 
Reply With Quote
  #7  
Old 05-18-2018, 10:37 AM
glc's Avatar
glc
glc is offline
Senior Member
Join Date: Dec 2006
Location: Joplin MO
Posts: 36,593
Motorcraft SP479. No antiseize, torque to 28 ft/lb.
 
Reply With Quote
  #8  
Old Today, 01:13 AM
Senior Member
Join Date: Jul 2004
Location: Easton, Pa.
Posts: 5,747
Sounds much like a lack of fuel pressure.
1. Wide open throttle does not use OX sensor inputs. The computer switches to rich fixed fuel tables at about 7/8 throttle positions.
2. Codes 171/174 richens fuel by moving fuel tables rich. This is what sets the codes.
.
The motor needs more fuel under all these conditions.
Good luck.
 
Reply With Quote
 
 
 


Thread Tools
Search this Thread
Sponsors

Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: