Go Back   F150online Forums > Powertrain & Mechanical > V8 Engines
Sign in using an external account
Register Forgot Password?
Register Photos Vin Decoder FAQ Members Search Today's Posts Mark Forums Read Vendor DirectoryGarage

Welcome to F150Online Forums!
Welcome to F150Online.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the F150Online Forums community today!





Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
  #1  
Old 06-17-2013, 11:47 PM
Junior Member
Garage is empty, add now
 
Join Date: Aug 2011
Vehicle: 2003 Ford F150
Posts: 5
5.4 Triton

Whats up fellas I have an 03 F-150 5.4 triton V8. Engine is misfiring and I cant figure out what exactly my problem is. It happens randomly any way I drive. If anyone could point me in the right direction or help me narrow down my problem id appreciate it.
Thanks, Nick
Reply With Quote
  #2  
Old 06-18-2013, 01:59 AM
glc glc is offline
Senior Member
Garage is empty, add now
 
Join Date: Dec 2006
Location: Joplin MO
Vehicle: 2003 Ford F150
Posts: 28,254
How many miles on the truck? How many miles on the spark plugs, and what brand are they? Have any of the coils ever been changed? No CEL? Have you checked for codes?
__________________
2003 F-150 XL RCSB 2wd 4.2 M5OD 3.55 LS
Reply With Quote
  #3  
Old 06-18-2013, 11:22 PM
Junior Member
Garage is empty, add now
 
Join Date: Aug 2011
Vehicle: 2003 Ford F150
Posts: 5
It has 206k miles and between 20k and 30k on my plugs and I have changed cylinder 1 coil pack. have not had a CEL at all and I havent been able to pull any codes at all either.
Reply With Quote
  #4  
Old 06-19-2013, 10:10 AM
glc glc is offline
Senior Member
Garage is empty, add now
 
Join Date: Dec 2006
Location: Joplin MO
Vehicle: 2003 Ford F150
Posts: 28,254
What BRAND are the plugs?

I'd put a bottle of Techron in the gas. If the injectors are dirty this will help clean them.
__________________
2003 F-150 XL RCSB 2wd 4.2 M5OD 3.55 LS
Reply With Quote
Old 06-19-2013, 10:10 AM


 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


All times are GMT -4. The time now is 11:10 AM.


 
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company
Contact Us Advertising Privacy Statement Terms of Service Jobs Forum Text Archives
Emails & Contact Details

Search Engine Friendly URLs by vBSEO 3.5.2