Go Back   F150online Forums > Powertrain & Mechanical > V8 Engines
Sign in using an external account
Register Forgot Password?
Register Photos Vin Decoder FAQ Members Search Today's Posts Mark Forums Read Vendor DirectoryGarage

Welcome to F150Online Forums!
Welcome to F150Online.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the F150Online Forums community today!





Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
  #1  
Old 06-16-2011, 12:31 AM
Senior Member
Garage is empty, add now
 
Join Date: Dec 2001
Location: Phoenix
Vehicle: 2006 Ford F150
Posts: 146
2006, 5.4- No vacuum to brake booster after backfire

I started my 2006 F150 yesterday and it backfired. Its only got 35000 miles on it and is rarely driven. After starting it again I put it in gear and got a big surprise when the brakes didn't work!
I got it home and pulled the vacuum line off the vacuum booster and there is no vacuum. Listening I don't hear any signs of vacuum leaks, the hoses all appear good with no weathering, splits or cracks and the engine runs just fine?

Is there a check valve or something else that could be plugged or jammed from the backfire?
Reply With Quote
  #2  
Old 06-16-2011, 07:30 AM
Technical Article Contributor
Garage is empty, add now
 
Join Date: Oct 2006
Location: Michigan
Vehicle: 1997 Ford F150 4.6
Posts: 1,626
Pull the line completely off and check for a blockage. While its off check at the port itself for vac. Something (crude) probably came loose and is blocking the line or vac port. Might want to explore why you had a backfire in the first place.
Reply With Quote
  #3  
Old 06-16-2011, 11:51 PM
Senior Member
Garage is empty, add now
 
Join Date: Dec 2001
Location: Phoenix
Vehicle: 2006 Ford F150
Posts: 146
Been doing some research and found Ford did a recall on the 05-06 F-150s with the 3 valve 5.4 for this very reason. Now all I have to do is get it into a dealer for replacement.
__________________
2006 F-150 XLT Scab 5.4L 3.73LS
Wedgewood Blue/AZ Biege two tone
tinted windows
Magnaflow
2" drop shackles
Lariat flares
Extang Full Tilt tonneau
Reply With Quote
  #4  
Old 06-18-2011, 07:35 AM
Senior Member
Garage is empty, add now
 
Join Date: Nov 2006
Location: New Lenox, IL
Vehicle: 2005 Ford F-150
Posts: 188
Quote:
Originally Posted by AZDesertRat View Post
Been doing some research and found Ford did a recall on the 05-06 F-150s with the 3 valve 5.4 for this very reason. Now all I have to do is get it into a dealer for replacement.
You should have received a letter from Ford about this recall. I am not the original owner of my F150 and I did over a year ago I believe. The Dealership had my truck for most of the day.
Reply With Quote
  #5  
Old 06-22-2011, 04:56 AM
Senior Member
Garage is empty, add now
 
Join Date: Dec 2001
Location: Phoenix
Vehicle: 2006 Ford F150
Posts: 146
Took it in Saturday and 3.5 hours later I had it back.
While I was there I asked about the spark plug fiasco and was told it would be $272 to replace them plus an additional hours labor for each one that broke. Ford really screwed up on this one and I am very disappointed thye are not standing behind it. This is my fifth Ford pickup and have had 3 new Ford cars for the wife and thats how they treat their loyal customers?
__________________
2006 F-150 XLT Scab 5.4L 3.73LS
Wedgewood Blue/AZ Biege two tone
tinted windows
Magnaflow
2" drop shackles
Lariat flares
Extang Full Tilt tonneau
Reply With Quote
Old 06-22-2011, 04:56 AM


 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


All times are GMT -4. The time now is 07:48 PM.


 
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company
Contact Us Advertising Privacy Statement Terms of Service Jobs Forum Text Archives
Emails & Contact Details