Knock sensor on 95 5.0??? - F150online Forums

Log In 


Pre-1997 Models

Knock sensor on 95 5.0???

Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 02-07-2002, 10:23 PM
Senior Member
Thread Starter
 
Join Date: Apr 1999
Location: white bear lake,mn, USA
Vehicle: 1995 ford f-150
Posts: 128
Knock sensor on 95 5.0???

I have a 95 5.0 150 and I'm trying to sort all the problems out with it...as i'm sure you can tell by all my posts anyways...i'm getting a "knock sensor not detected" code or something close to that (I forget what the number is)

Do 5.0s even have knock sensors? I didn't think so, but I could be wrong?? If they do, where is it? I've looked all over and can't find it.

BTW: I have a pinging problem with the truck as well.

Thanks alot,
scott
Reply With Quote
  #2  
Old 02-08-2002, 06:57 PM
Senior Member
 
Join Date: Aug 2001
Location: Smithton MO
Vehicle: 1992 FORD F250
Posts: 292
Your knock sensor is on the very back of the motor.(right on top of the engine block itself). Trust me it is a major pain to get too,but it is there.
Reply With Quote
  #3  
Old 02-08-2002, 07:40 PM
Senior Member
 
Join Date: Feb 2002
Location: NoWhere :)
Vehicle: 1990 Ford f150
Posts: 701
i am lookinmg at a picture of componant locations in my book right now and it looks to be under the plenium near the rear of the motor
Reply With Quote
  #4  
Old 02-08-2002, 07:46 PM
Senior Member
 
Join Date: Sep 1999
Location: Ventura, California
Vehicle: 1995 Ford F150
Posts: 3,083
Before you replace it, make sure you performed the KOER self test correctly. If you failed to reach WOT when prompted, a knock sensor code will come up.

Take care,
-Chris
Reply With Quote
  #5  
Old 02-08-2002, 10:47 PM
Senior Member
 
Join Date: Jan 2002
Location: Maine
Vehicle: 1993 ford F150
Posts: 880
Check the base time for the pinging.
Reply With Quote
  #6  
Old 02-11-2002, 02:01 AM
Senior Member
Thread Starter
 
Join Date: Apr 1999
Location: white bear lake,mn, USA
Vehicle: 1995 ford f-150
Posts: 128
Thanks for the help!

-scott
Reply With Quote
  #7  
Old 02-17-2002, 01:49 AM
Senior Member
 
Join Date: Dec 2001
Location: central california
Vehicle: 2002 Ford F150
Posts: 254
lack of egr flow will cause pinging. but i think pkrwud is right. you need that wot when doing koer. if you dont it will give you that code. and nothing is wrong.
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Getting bad mileage jrossjr79 1997 - 2003 F-150 17 02-22-2016 03:12 AM
p0420 code help thais0n 2004 - 2008 F-150 4 10-02-2015 03:27 PM
M5Od Slave replacement- now ABS light and no A/C Raptor05121 Transmissions 5 09-30-2015 08:44 AM
2005 FX4 5.4 Knock/Tap and rough idle (VCT / phaser?) jrudn154 V8 Engines 3 09-29-2015 09:14 AM
2008 f150 5.4 samsonf150 V8 Engines 1 09-26-2015 05:43 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



All times are GMT -4. The time now is 04:43 PM.


This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Fordé is a registered trademark of the Ford Motor Company