'94 losing coolant but no leaks? - F150online Forums



Pre-1997 Models

'94 losing coolant but no leaks?

Reply
 
 
  #1  
Old 04-09-2012, 07:26 AM
Junior Member
Thread Starter
 
Join Date: Apr 2012
Location: South GA
Posts: 1
'94 losing coolant but no leaks?

I have a 94 F150 with the 5.8 V8 that I rarely drive. I've been having problems holding coolant for quite awhile. I replaced the water pump about a year ago and that seemed to help some but now everytime I drive it (about once a month) I need to add coolant.

I can't find any leaks but it's bone dry. Anybody have any ideas? I'm pretty lost.
Reply With Quote
  #2  
Old 04-18-2012, 06:20 PM
Senior Member
 
Join Date: Aug 2010
Location: Cabot, AR
Posts: 1,185
Have you checked the oil? Is it milky white?
Do you smell coolant?
What about the tailpipe(s), is there any coolant there?

Also, check the drivers side freeze plugs and oil pan for leaks. Also check the y-pipe just aft of the crossmember. Are there any white streak marks/coolant trails?
Reply With Quote
 
 
Reply

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
05F150Tex
2004 - 2008 F-150
29
04-06-2016 01:12 AM
violator80
2004 - 2008 F-150
10
01-30-2016 02:09 AM
dput8
Suspension
11
10-04-2015 03:30 AM
02xltscab
V6 Engines (including Ecoboost)
1
09-29-2015 04:30 PM
02xltscab
Transmissions
3
09-26-2015 04:56 PM


Thread Tools
Search this Thread

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



All times are GMT -4. The time now is 08:15 PM.