Go Back   F150online Forums > F-Series Trucks > Pre-1997 Models
Sign in using an external account
Register Forgot Password?
Register Photos Vin Decoder FAQ Members Search Today's Posts Mark Forums Read Vendor DirectoryGarage

Pre-1997 Models

Welcome to F150Online Forums!
Welcome to F150Online.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the F150Online Forums community today!





Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
  #1  
Old 02-25-2012, 09:38 PM
Member
1995 Ford F-150
 
Join Date: Oct 2011
Location: Hegins, Pa
Vehicle: 1995 Ford F150
Posts: 31
rough idle after warm up

Hi all, I have a 95 f150 302 auto 234,000 miles, been tuned up, plugs wires cap rotor fuel filter air filter, last week i took the upper plenum off cleaned it out with carb\intake cleaner (was really caked up with carbon) pulled the injectors cleaned them and rebuilt them new o rings screens pintle caps, replaced the gaskets cleaned the iac egr has been blocked off for years. engine runs\idles great cold after warm up it idles rough sometimes put lite throttle to it and it really misses like air before fuel then push the throttle more and runs fine did a vacum check all good sprayed starting fluid around all posible leak spots nothing checked tps (good) o2 sensor is the only thing i havent checked, no cel. ran rough till i did the cleaning then ran great till i took it for a ride then the rough idle started does it in park and in gear. the only thing i think it could be is weak injectors or a bad o2 sensor. all input is greatly appreciated thanks.
Reply With Quote
  #2  
Old 02-26-2012, 06:08 AM
glc glc is offline
Senior Member
Garage is empty, add now
 
Join Date: Dec 2006
Location: Joplin MO
Vehicle: 2003 Ford F150
Posts: 28,286
You might have to replace the IAC.
__________________
2003 F-150 XL RCSB 2wd 4.2 M5OD 3.55 LS
Reply With Quote
  #3  
Old 02-26-2012, 09:48 AM
Senior Member
1990 Ford F-150
My Garage
 
Join Date: Aug 2010
Vehicle: 1990 ford f150
Posts: 505
when u rebilt the injectors u didnt snap the tiny adamizer off the end when u were taking the old caps off did u. its an easy thing to over look ive done it once myself. and it caused a shutter a 1700 rpm and rough idle
__________________
6 in a row makes it go. big block 6
1990 ford f150 xlt single cab long box 4x2 4.9 strait 6 b/w t18 4 speed 3.55
Reply With Quote
  #4  
Old 02-26-2012, 03:12 PM
Member
1995 Ford F-150
 
Join Date: Oct 2011
Location: Hegins, Pa
Vehicle: 1995 Ford F150
Posts: 31
thanks for the replies, i figured it out and you aint going to believe what it was. i took everything apart again and checked, cleaned, and reasembled everthing i had off, still did it. (wtf really pissin me off) thought i would recheck the distributor for play, put it back in and hooked my timming light up and when i unplugged the little button on the fender it stopped running rough idled real smooth here i must've not tighted the hold down bolt enough and the distributor moved last time after reassemble so no more miss and rough idle. WOW!!! so thanks for the help.
Reply With Quote
  #5  
Old 02-29-2012, 10:06 PM
Member
Garage is empty, add now
 
Join Date: Oct 2011
Location: Jax,FL
Vehicle: 1993 Ford F-150
Posts: 15
ok so what was the "little button" ???
Reply With Quote
  #6  
Old 02-29-2012, 10:23 PM
Senior Member
1990 Ford F-150
My Garage
 
Join Date: Aug 2010
Vehicle: 1990 ford f150
Posts: 505
hes probly talkin about the spout conector
__________________
6 in a row makes it go. big block 6
1990 ford f150 xlt single cab long box 4x2 4.9 strait 6 b/w t18 4 speed 3.55
Reply With Quote
  #7  
Old 03-04-2012, 03:35 PM
Member
1995 Ford F-150
 
Join Date: Oct 2011
Location: Hegins, Pa
Vehicle: 1995 Ford F150
Posts: 31
yes sorry i forgot the name of it it is the spout connector
Reply With Quote
  #8  
Old 03-04-2012, 04:32 PM
Senior Member
1990 Ford F-150
My Garage
 
Join Date: Aug 2010
Vehicle: 1990 ford f150
Posts: 505
yea the spout makes the distributer not advance so u can time it its the same as taking the vacum line off the vac advance distributer
__________________
6 in a row makes it go. big block 6
1990 ford f150 xlt single cab long box 4x2 4.9 strait 6 b/w t18 4 speed 3.55
Reply With Quote
Old 03-04-2012, 04:32 PM


 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


All times are GMT -4. The time now is 05:51 PM.


 
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company
Contact Us Advertising Privacy Statement Terms of Service Jobs Forum Text Archives
Emails & Contact Details