Go Back   F150online Forums > F-Series Trucks > Pre-1997 Models
Sign in using an external account
Register Forgot Password?

Pre-1997 Models

Welcome to F150Online Forums!
Welcome to F150Online.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the F150Online Forums community today!





Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
  #1  
Old 08-14-2011, 10:18 PM
Junior Member
 
Join Date: May 2011
Location: Maryland
Vehicle: 1991 Ford F150
Posts: 4
1991 5.0 missing running rough and oil loss

List

I have a 1991 4x4 5.0 with an E4OD transmission 115,000 +_ miles. The truck has a miss that has gotten worse. I have changed plugs , wires rotor and cap. In addition I have replaced the vacuum reservoir that was shot, cleaned the throttle body , changed the fuel filter etc. I have had the codes pulled and I have got the following : 328,(EGR ) evap voltage, 332 EGR not opening, 542, Fuel pump ground and 634 Manual Lever Position Sensor. In addition to the missing I have found oil in the air cleaner, I replaced the PCV valve with a Motorcraft one when i discovered the oil issue. My question is this is the ERG issue causing both the missing and the oil in the air cleaner issues? or do I have more than one thing going one? I have the correct voltage ( 5.0) at the EGR sensor but I have not been able to test the sensor yet.

Any guidance would be appreciated.

Thanks

Jim Barringer
Reply With Quote
  #2  
Old 08-14-2011, 11:27 PM
Senior Member
 
Join Date: Aug 2010
Vehicle: 1990 ford f150
Posts: 505
im not sure if the egr would cause the oil but my buddys 94 5.0 ran rough at idle and had the same codes and we put a new egr valve on and it went away. nowhis egr came off easy my 90 i broke the egr tube and had to replace the whole thing so pb blaster the hell out of it
__________________
6 in a row makes it go. big block 6
1990 ford f150 xlt single cab long box 4x2 4.9 strait 6 b/w t18 4 speed 3.55
Reply With Quote
  #3  
Old 08-15-2011, 12:19 PM
Senior Member
 
Join Date: Nov 2006
Location: Memphis, TN 38135, USA, Earth
Vehicle: 1983 Ford Bronco
Posts: 5,334
Those definitions aren't accurate or complete; read this caption:



Don't pick the name of a part out of the definition - read & post the WHOLE thing. The EGR can't cause oil in the filter, and it can only cause a miss near idle; not at highway speed. Read these captions:

. . . . . .
__________________
Walk softly & carry a BIG SIX ! ! !

. . .
Reply With Quote
Old 08-15-2011, 12:19 PM


 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


All times are GMT -4. The time now is 12:24 AM.


 
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company
Contact Us Advertising Privacy Statement Terms of Service Jobs Forum Text Archives
Emails & Contact Details