1997 F150 GEM Module - F150online Forums



1997 F150 GEM Module

Reply
 
 
  #1  
Old 03-28-2011, 07:44 PM
Member
Thread Starter
 
Join Date: Nov 2008
Location: Minnesota
Posts: 24
1997 F150 GEM Module

Looking for a used non corroded GEM Module for a 1997 Ford F150 with the 4.6L XLT 2WD. Mine i guess got water inside the cabin and onto the fuse block and gem module and corroded everything and now i get the awsome dash lights on draining battery problems.

Let me know what you guys have im trying to do this as cheap as possible since my truck is a rusty truck with higher miles but my daily driver and winter vehicle.
Reply With Quote
  #2  
Old 03-28-2011, 08:29 PM
Senior Member
 
Join Date: Sep 2009
Location: Bear, Delaware
Posts: 1,695
If another member does not have one for you cheaper..... Ebay has some. $95-120.00 .... just copy n paste your thread title for the search
Reply With Quote
  #3  
Old 03-28-2011, 08:44 PM
Member
Thread Starter
 
Join Date: Nov 2008
Location: Minnesota
Posts: 24
Yea im on ebay now, i need to pull the numbers off the GEM so i can get the correct module other wise it might not work or need to be reprogramed.

This is really sad that all i do is a google search and hear about all the people who have the same problems i have due to fords design on how water gets inside and drips ontop of the fuse box and gem module yet they wont acknowledge the problem and admit its a design fault.
Reply With Quote
  #4  
Old 03-28-2011, 09:10 PM
Senior Member
 
Join Date: Sep 2009
Location: Bear, Delaware
Posts: 1,695
Good Luck with it. I should check mine when it gets warmer even though I don't have any issues............................... YET
Reply With Quote
  #5  
Old 03-28-2011, 09:23 PM
Member
Thread Starter
 
Join Date: Nov 2008
Location: Minnesota
Posts: 24
Quote:
Originally Posted by Red02FX4 View Post
Good Luck with it. I should check mine when it gets warmer even though I don't have any issues............................... YET
I take it you prob still have your original windsheild still?
I hear the problem can also be from having windsheild replacements and water creeping in somwhere.
Reply With Quote
  #6  
Old 03-28-2011, 09:44 PM
Senior Member
 
Join Date: Sep 2009
Location: Bear, Delaware
Posts: 1,695
Actually....... I don't know if it is the original. I will have to look at the stamps. I know I have not had it replaced since I got it nearly 2 years ago
Reply With Quote
  #7  
Old 03-30-2011, 05:19 AM
Member
Thread Starter
 
Join Date: Nov 2008
Location: Minnesota
Posts: 24
Anything guys?
Reply With Quote
  #8  
Old 02-13-2012, 08:47 PM
Junior Member
 
Join Date: Sep 2009
Location: Weatogue, Ct
Posts: 6
Gem Mod and fuse 15

Please Delete

Last edited by ctguy1955; 02-13-2012 at 08:53 PM. Reason: posted in its own thread
Reply With Quote
 
 
Reply

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
twillroth
Parts & Accessories For Sale (2009 - 2014)
0
07-24-2015 11:26 PM
rake1
2015 - 2016 F-150
9
07-21-2015 04:35 PM
Estrada94
1997 - 2003 F-150
1
07-09-2015 10:00 PM


Thread Tools
Search this Thread

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



All times are GMT -4. The time now is 09:31 AM.