Go Back   F150online Forums > F-Series Trucks > F-250 / Super Duty / Diesel
Sign in using an external account
Register Forgot Password?
Register Photos Vin Decoder FAQ Members Search Today's Posts Mark Forums Read Vendor DirectoryGarage

F-250 / Super Duty / Diesel

Welcome to F150Online Forums!
Welcome to F150Online.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the F150Online Forums community today!





Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
  #1  
Old 06-12-2011, 08:39 PM
Member
Garage is empty, add now
 
Join Date: Aug 2010
Location: NC
Vehicle: 2007 Ford F250
Posts: 11
07 Brake lights\Rear Turn Signal\Rear Flashers Not Working

I have an 07 F250. I have the factory tow package and have been towing a 14ft trailer. I noticed the other day that the blinkers were blinking faster than usual. Checked all the lights and everything worked except for the truck brake and blinkers. Trailer lights worked fine other than a faster than usual blink. Dropped the trailer and when I checked the truck lights I found that: -rear brake lights didn't work
-rear turn signals didn't work
-rear flasher didn't work
-rear driving lights worked as did the license plate light
***All lights in the front worked***

Checked: All fuses under steering wheel and under the hood.
Contacts in the trailer jack.
Contacts in the steering column(possible pulled wire from tilt wheel)
Grounds to the frame in the rear

Brake switch should be ok since the trailer brake lights work right?
Flasher should be ok since the truck front and trailer blinkers and 4 ways work also right?
Been researching this for a few days. I wanna drop this trailer but I cant until the truck rear lights are resolved. Any help would be greatly appreciated.
Reply With Quote
  #2  
Old 06-14-2011, 06:37 PM
Member
Garage is empty, add now
 
Join Date: Aug 2010
Location: NC
Vehicle: 2007 Ford F250
Posts: 11
Changed the bulbs and everything is fine....cheapest fix first
Reply With Quote
Old 06-14-2011, 06:37 PM


 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


All times are GMT -4. The time now is 05:49 AM.


 
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company
Contact Us Advertising Privacy Statement Terms of Service Jobs Forum Text Archives
Emails & Contact Details

Search Engine Friendly URLs by vBSEO 3.5.2