Go Back   F150online Forums > F-Series Trucks > F-250 / Super Duty / Diesel
Sign in using an external account
Register Forgot Password?


F-250 / Super Duty / Diesel

Welcome to F150Online Forums!
Welcome to F150Online.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the F150Online Forums community today!





Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
  #1  
Old 11-14-2007, 12:36 AM
Member
 
Join Date: Dec 2001
Location: Livermore Ca
Vehicle: 2008 Ford F250
Posts: 39
Exclamation 2008 Ford F250 6.4 Diesel stalled!!

I'm checking to see if this has happened to anyone else. My 2008 Ford F250 stalled on me while I was driving. I was on the frewway doing about 80mph for about 100 miles. I then got off the freeway to drive thru town and then my CHECK ENGINE light came on and about 2 seconds later the truck shut it self off. The message center said Stop safely now. At that point I tried to start the truck and it was dead. Nothing happened. 40 minutes later after the tow truck had already put my truck on the flat bed I tried to start it and it started. I took it to Ford they ran there tests and said there was nothing wrong with the truck.
Has this happened to anyone else??
Reply With Quote
  #2  
Old 11-14-2007, 12:43 AM
Senior Member
 
Join Date: Jul 2004
Location: Nashville, TN
Vehicle: 2008 Ford F250
Posts: 4,476
Nope! I have 10,000 miles on my 08 and nothing like that has happened to me. Maybe water in the fuel or something like that?
Reply With Quote
  #3  
Old 11-14-2007, 10:27 AM
Technical Article Contributor
 
Join Date: Jan 2007
Location: Vernon, NY
Vehicle: 2007 Ford F150
Posts: 5,744
That's like Ford telling me there is nothing wrong with my truck pinging the way it is.

I'm beginning to wonder about these dealers lately...
Reply With Quote
  #4  
Old 11-14-2007, 04:34 PM
Senior Member
 
Join Date: Nov 2004
Location: Airdrie, AB
Vehicle: 2007 Ford F150
Posts: 645
If it flagged a code as it would have if your CEL came on, then it will be stored in the PCM. Go to another dealer who is not so lazy. This should be an easy one for them to diagnose unless maybe the battery was disconnected in between the stall and the dealer looking at it, or a reflash was done (like removing a tuner if you were running one).
__________________
06' F-350 Harley Davidson PSD, 4" Cage Offroad lift, magnaflow exh, 35" Toyo M/T's
Check this out...
Reply With Quote
  #5  
Old 11-15-2007, 12:38 AM
Member
 
Join Date: Dec 2001
Location: Livermore Ca
Vehicle: 2008 Ford F250
Posts: 39
2008 Ford F250

I did take the truck to A local Ford dealer where my buddy is the service manager and I was there when they ran the tests and no codes came up. They did try to tell me that it may have been because I an installed an AFE air filter system, but couldnt be sure since there were no codes.
Reply With Quote
  #6  
Old 11-15-2007, 12:40 AM
Member
 
Join Date: Dec 2001
Location: Livermore Ca
Vehicle: 2008 Ford F250
Posts: 39
2008 Ford F250

I did take the truck to A local Ford dealer where my buddy is the service manager and I was there when they ran the tests and no codes came up. They did try to tell me that it may have been because I an installed an AFE air filter system, but couldnt be sure since there were no codes. I was wondering has anyone tried to put a tuner in there truck like the Hypertech?
Reply With Quote
  #7  
Old 02-05-2011, 01:33 PM
Junior Member
 
Join Date: Feb 2011
Posts: 1
This just happened to me, what was your diagnosis?
Reply With Quote
  #8  
Old 02-05-2011, 08:17 PM
Senior Member
 
Join Date: Dec 2004
Location: Dover AFB DE / Harrisburg PA
Vehicle: 11 FULLsize ole' Ford rigs
Posts: 4,930
Send a message via AIM to adrianspeeder Send a message via MSN to adrianspeeder Send a message via Yahoo to adrianspeeder
Welcome Mike. Sorry to hear about your truck. Might want to take a look for more answers at www.thedieselgarage.com in the 6.4L section.

How many miles do you have?

Adrianspeeder
__________________
Reply With Quote
  #9  
Old 02-05-2011, 09:22 PM
Senior Member
 
Join Date: Sep 2002
Location: Canada
Vehicle: 2003 Ford F250
Posts: 557
Back when I was a diesel tech at a dealer, I had a 08 6.4 that stalled after driving for a long time. I spent hours driving it with the IDS trying to verify the concern. After a while it died and I had to get a ride back to the dealer. It lost fuel pressure on the high side. Ended up changing the high pressure fuel pump and that fixed it up.
Don't know if this helps or not but it may give you something to think about.
Good luck.
Reply With Quote
Old 02-05-2011, 09:22 PM


 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


All times are GMT -4. The time now is 08:16 AM.


 
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company
Contact Us Advertising Privacy Statement Terms of Service Jobs Forum Text Archives
Emails & Contact Details