Oil pressure/engine coolant light - F150online Forums

Go Back   F150online Forums > F-Series Trucks > Expedition / Navigator
Log In 

Expedition / Navigator

Oil pressure/engine coolant light

Thread Tools Search this Thread
Old 02-23-2011, 03:47 PM
Junior Member
Join Date: Nov 2002
Vehicle: 1999 Ford Expedition
Posts: 3
Oil pressure/engine coolant light

On my 99 4x4 XLT Expy (5.4L) the Oil pressure/engine coolant light and the Service Engine Soon light both stayed on when I started it today. The oil and coolant levels are fine. The oil pressure gauge is indicating as it normally does. I took it for a ride of about 5 miles,
the temperature gauge did not move. Also the AC is not blowing cold now, I assume it is related.

Will there be code thrown since the SES light is on?

Temperature sending unit bad? Where is the sending unit located on a 5.4L?

Bob W [FL]
Reply With Quote


Similar Threads
Thread Thread Starter Forum Replies Last Post
2005 5.4 "Project" data_engine V8 Engines 2 08-06-2015 09:52 AM
2002 5.4L - 170,000 Miles - Tuneup list.. kev2126 1997 - 2003 F-150 9 07-25-2015 10:30 AM
2010 Spark Plug change and coolant flush F 1Fiddy 2009 - 2014 F-150 7 07-16-2015 03:43 PM
What is this in coolant. 10thGenF150ty V8 Engines 2 07-14-2015 12:33 AM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off

All times are GMT -4. The time now is 07:48 PM.

This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Fordé is a registered trademark of the Ford Motor Company