Go Back   F150online Forums > F-Series Trucks > Expedition / Navigator
Sign in using an external account
Register Forgot Password?


Expedition / Navigator

Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
  #1  
Old 08-07-2007, 09:58 AM
Junior Member
 
Join Date: Oct 2003
Vehicle: 1998 Ford Expedition
Posts: 3
98 Expy 4x4 selector switch no power

Found 10 amp fuses 23 & 24 intermittant in fuse box under dash intermittant.
Replaced both all ok now
Reply With Quote
  #2  
Old 05-10-2008, 12:25 PM
Junior Member
 
Join Date: Oct 2003
Vehicle: 1998 Ford Expedition
Posts: 3
This failure just happened to me again and after checking all fuses etc. I pulled the neg battery cable for 5 minutes and reconnected proble resolved.
When in doubt reboot!
Reply With Quote
Old 05-10-2008, 12:25 PM


 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


All times are GMT -4. The time now is 01:24 AM.





This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company
 
Contact Us Advertising Privacy Statement Terms of Service Jobs Forum Text Archives
Emails & Contact Details