Factory Amp Location - F150online Forums



Expedition / Navigator

Factory Amp Location

Reply
 
 
  #1  
Old 07-06-2006, 11:48 PM
Junior Member
Thread Starter
 
Join Date: Jul 2006
Posts: 4
Factory Amp Location

Seems as though the factory amp in my 2000 Expedition w/Premium Audio has stopped working. Where is it located and how do I get to it? Also would anybody know what harness to use to bypass the amp.

Thanks
Reply With Quote
  #2  
Old 07-07-2006, 05:26 PM
Member
 
Join Date: Jul 2006
Location: Texas
Posts: 34
I went through this sometime back. I was told by a stereo shop that the factory amp was located behind one of the rear panels. I have a 98 by the way. After removing all the rear panels, I never found it. I knew that I would have to bypass it to run an amp, so I did things the hard way. I located the factory speaker wires under the door sills, and ran new wire from there to the amp. It was only after all that, while installing the radio I found the factory amp. Directly behind and below the stock radio. Look there first.

Pull the black cover off that is located below the dash and on top of the wheel well. Look up under the dash behind the radio. If it is located there, it would be easy to see.

Now mine did not have a stock subwoofer. It very well could be different if your has a stock subwoofer.
Reply With Quote
  #3  
Old 07-07-2006, 07:27 PM
Junior Member
Thread Starter
 
Join Date: Jul 2006
Posts: 4
Quote:
Originally Posted by tj4840
I went through this sometime back. I was told by a stereo shop that the factory amp was located behind one of the rear panels. I have a 98 by the way. After removing all the rear panels, I never found it. I knew that I would have to bypass it to run an amp, so I did things the hard way. I located the factory speaker wires under the door sills, and ran new wire from there to the amp. It was only after all that, while installing the radio I found the factory amp. Directly behind and below the stock radio. Look there first.

Pull the black cover off that is located below the dash and on top of the wheel well. Look up under the dash behind the radio. If it is located there, it would be easy to see.

Now mine did not have a stock subwoofer. It very well could be different if your has a stock subwoofer.
Alright, I shall go find it today, hopefully
Reply With Quote
  #4  
Old 07-07-2006, 09:30 PM
Junior Member
Thread Starter
 
Join Date: Jul 2006
Posts: 4
I think I have found the wire to it, but I cannot see a box going to it. Any ideas?
Reply With Quote
  #5  
Old 07-14-2006, 02:22 AM
Junior Member
 
Join Date: Jun 2006
Location: Omaha, Nebraska
Posts: 7
the sub amp is back behind the passanger side wheel well just in front of the factory 8"Sub you have to take the whole side panel off.

The amp for the door speakers is in the dash behind the factory stereo.

You must remove the factory stereo to get access to it.

hope this helps
Reply With Quote
  #6  
Old 07-18-2006, 02:38 AM
Junior Member
Thread Starter
 
Join Date: Jul 2006
Posts: 4
Hate to keep bumping this thread, but I have found the ever elusive rear speaker amplifier. While running speaker wire I found that it is mounted on the floor of the truck in front of the console. Its a silver box with two black plugs comming out of it.
Reply With Quote
  #7  
Old 08-03-2006, 03:00 AM
Junior Member
 
Join Date: Feb 2003
Location: Maryland
Posts: 28
How do you get the plastic that houses the factory sub? Do you have to remove the seatbelt bolt for the second row passenger?

Last edited by madjay97; 08-05-2006 at 07:45 PM.
Reply With Quote
 
 
Reply

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
ab46501
2015 - 2016 F-150
44
11-30-2016 01:51 PM
klhmn
Parts & Accessories For Sale (2009 - 2014)
2
10-12-2015 07:58 AM
tbaz
Amplifiers
13
09-15-2015 09:18 PM
klhmn
Trucks For Sale (2004 - 2014)
0
09-13-2015 11:29 AM
Haz-matt
SuperCrew
1
09-07-2015 01:24 AM


Thread Tools
Search this Thread

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



All times are GMT -4. The time now is 08:02 PM.