Fuse 6 keeps blowing - F150online Forums


Fuse 6 keeps blowing

Reply
 
 
  #1  
Old 09-26-2010, 03:37 PM
Senior Member
Thread Starter
 
Join Date: Jul 2008
Location: arkansas
Posts: 682
Fuse 6 keeps blowing

I have a 06 f150 and recently i had the #6 fuse blow and when i replace it and turn the ignition on it blows again.It controls my fog lights, parking lights, dash illumination. I know nothing about electrical systems and any help is much appreciated.
Reply With Quote
  #2  
Old 09-26-2010, 05:59 PM
Senior Member
Thread Starter
 
Join Date: Jul 2008
Location: arkansas
Posts: 682
any advice is appreciated
Reply With Quote
  #3  
Old 09-26-2010, 07:38 PM
Senior Member
 
Join Date: Oct 2009
Location: Corona, Crazyfornia
Posts: 2,515
Do you have daytime running lights? Are the fogs after market or factory?

If you have dtrl then try putting the parking brake on and trying it like that. If it doesn't blow then I would suspect something in the DTRL system.

Check the wires on the fogs and any other you can see that are connected to the lights where the go through or lay on metal body parts.

Both of those suggestions are only guesses, but at least it's a start.
Good luck.
Reply With Quote
  #4  
Old 09-26-2010, 10:45 PM
Senior Member
Thread Starter
 
Join Date: Jul 2008
Location: arkansas
Posts: 682
i have driving lights but i disconnected them from the battery and i had hids in the fogs but i took them out and it still blows but ill try that tomorrow
Reply With Quote
  #5  
Old 09-27-2010, 07:51 PM
Senior Member
Thread Starter
 
Join Date: Jul 2008
Location: arkansas
Posts: 682
I tried that today and still blowing
Reply With Quote
  #6  
Old 09-27-2010, 11:19 PM
Senior Member
 
Join Date: Jun 2009
Location: pittsburgh pa
Posts: 178
I have a similar problem on my 98 Expy. Every time it rains , it blows the fuse for my dash lights. What's the deal?
Reply With Quote
  #7  
Old 09-28-2010, 10:16 AM
Technical Article Contributor
 
Join Date: Jun 2002
Location: Under the flightpath of old ORD 22R
Posts: 10,495
The fog lamps you added ?
- If you did, do you have the switch for the relay attached to the parking lamps ?

- The HID kit in the factory fog lamps, how is that wired in ( i.e. only plug and play for the bulb and ballasts, no other modifications ).

- Do you have DRLs installed ?
Reply With Quote
  #8  
Old 09-28-2010, 10:17 AM
Technical Article Contributor
 
Join Date: Jun 2002
Location: Under the flightpath of old ORD 22R
Posts: 10,495
Quote:
Originally Posted by stewy 39 View Post
I have a similar problem on my 98 Expy. Every time it rains , it blows the fuse for my dash lights. What's the deal?
Is this just the fuse for the cluster illumination, or the parking lamps ?
Reply With Quote
 
 
Reply

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
chuck2629
2004 - 2008 F-150
7
10-05-2015 08:52 AM
Raptor05121
Transmissions
5
09-30-2015 09:44 AM
judesson
Electrical Systems
1
09-30-2015 12:11 AM
jorgesapeg
2009 - 2014 F-150
1
09-28-2015 12:46 PM
rbthgrt
1997 - 2003 F-150
2
09-17-2015 10:22 PM


Thread Tools
Search this Thread

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 03:30 PM.