Left brake/turn signal light will not work - F150online Forums


Left brake/turn signal light will not work

Reply
 
 
  #1  
Old 10-05-2009, 12:04 AM
Member
Thread Starter
 
Join Date: May 2006
Location: Huntersville, NC
Posts: 97
Left brake/turn signal light will not work

My Left brake/turn signal light will not work on 2006 F150 SCAB. I replaced all bulbs but still does not work. The bumper and trailer wiring harness was replaced last week after I got rear-ended by a car. Does the wiring harness for the brake/turn signal light tie into the trailer wiring harness and maybe has come lose?
Thanks
Reply With Quote
  #2  
Old 10-05-2009, 09:59 AM
Technical Article Contributor
 
Join Date: Jun 2002
Location: Under the flightpath of old ORD 22R
Posts: 10,495
After the main rear connector, where the majority of the circuits get to the back ( this is a 2001 MY part number, but the same location ) along with where the trailer tow connector plugs in :



there is another connector C405 that the trucks circuits are at.

This connector the left is pin #4, Light Green w/ Orange stripe wire.

I would image that the wire is broken between C405 and the bulb connector ?

This is a SWAG, does the parking lamp work on the left side, or is that also out ? ( the thread only mentions the Stop / Turn circuit ).

C405 is a common connector that the stop / turn, park, reverse circuits all share, and is in the rear of the truck.

The Truck's stop / turn lamps are in the fuse slots for the trailer tow stop turn, on the supply side of the fuse. Same circuit from the MFS branches off prior to the trailer tow rear turn signal fuses. The left trailer tow fuse is F42, if you want to try a meter here. Next spot would be at C405 at the rear of the truck.
Reply With Quote
  #3  
Old 10-05-2009, 01:40 PM
Member
Thread Starter
 
Join Date: May 2006
Location: Huntersville, NC
Posts: 97
Thanks SSCULLY for the diagram and help.
I just got back from the shop and a connector was the problem. It was not snapped together all the way, simple fix.
All lights are working now.
Reply With Quote
  #4  
Old 10-05-2009, 01:46 PM
Technical Article Contributor
 
Join Date: Jun 2002
Location: Under the flightpath of old ORD 22R
Posts: 10,495
Good to hear it was an easy fix that they got resolved quickly.
Reply With Quote
 
 
Reply

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
TexasHarley06
2004 - 2008 F-150
16
01-20-2017 09:01 AM
kev2126
1997 - 2003 F-150
9
07-25-2015 11:30 AM
rivercity
Electrical Systems
2
07-20-2015 10:45 PM
Deerjager
HVAC
3
07-11-2015 09:06 AM


Thread Tools
Search this Thread

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 07:43 PM.