Go Back   F150online Forums > F-Series Trucks > 2009 - 2014 F-150
Sign in using an external account
Register Forgot Password?
Register Photos Vin Decoder FAQ Members Search Today's Posts Mark Forums Read VendorsGarage

2009 - 2014 F-150 SPONSORED BY:




Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
  #1  
Old 05-29-2011, 12:25 PM
Member
2010 Ford F-150
 
Join Date: Feb 2004
Vehicle: 2010 Ford F150
Posts: 33
Electrical Smell From Vents

When I turn on the AC I am getting an electrical smell coming from the vents. This started about two weeks ago. Not very strong, but it does smell like overheating electrical wires. I can't believe that there would be any wires running through the vent system, so all I can think of is the blower motor. Anyone else ever had a problem similar to this?
Reply With Quote
  #2  
Old 05-29-2011, 05:02 PM
Gir Gir is offline
Senior Member
Garage is empty, add now
 
Join Date: Dec 2009
Posts: 117
You sure it's not the common mold smell?
Reply With Quote
  #3  
Old 05-30-2011, 09:51 PM
Member
2010 Ford F-150
 
Join Date: Feb 2004
Vehicle: 2010 Ford F150
Posts: 33
It's definitely not mold. I had that in my last truck and it is a totally different smell. A buddy said it reminded him of the "new car smell", but I have had this for over a year now.

Guess I wait for it to ignite while going down the highway. JK.
Reply With Quote
  #4  
Old 06-01-2011, 09:03 AM
Senior Member
Garage is empty, add now
 
Join Date: Mar 1999
Location: N.E. Ohio
Vehicle: 2013 Ford F-150
Posts: 410
I have the same issue, along with a few others. Check out my thread titled "Burning Odor From Vents".
__________________

2013 F-150 Supercab 4x4 XLT, 5.0L, Ruby Red, Chrome Package, Ford Sportliner, Truxedo Lo-Pro, Bed Extender.
1989 F-150 Supercab 4x4 Longbed XLT Lariat, 5.8L/C-6 auto, Light Chestnut.
1979 F-350 Regular Cab 4x4 Custom, 460/C-6, Medium Vaquero/White.
Reply With Quote
  #5  
Old 09-21-2011, 07:06 PM
Junior Member
Garage is empty, add now
 
Join Date: Mar 2001
Posts: 8
Cool electrical from vents

Hey there, I bought a Ford F150 King Ranch May 2010, and about 6 to 8 months later I begin to smell a electrical smell from either the heat or AC. I thought maybe its the new car smell but its strong when you turn it on in the beginning. Especially the AC is more pronounce. Has anyone figured this out. It is going to the dealership on Monday. I will try to keep people informed.
Reply With Quote
  #6  
Old 09-23-2011, 12:55 PM
Senior Member
Garage is empty, add now
 
Join Date: Jun 2010
Posts: 482
Me too.

Turn on the HVAC and sniff, sniff "what is that smell".

Bought the '10 brand new just over a year ago but the smell did not start until approx. 6months ago.

Keith please let us know what the dealer tells you, thx.
Reply With Quote
  #7  
Old 09-23-2011, 07:48 PM
Senior Member
Garage is empty, add now
 
Join Date: Apr 2004
Location: Ann Arbor, MI
Vehicle: 2004 Ford F150
Posts: 108
Same smell in my 09....keep us updated.
Reply With Quote
  #8  
Old 09-23-2011, 08:52 PM
Senior Member
Garage is empty, add now
 
Join Date: May 2005
Location: White Lake, MI
Vehicle: 2011 Ford F150
Posts: 342
I've smelled the burning wire smell as well as the infamous "band-aid" smell coming from my '11 vents while AC is on
__________________
2011 Tuxedo XLT CrewCab EcoBoooost
Reply With Quote
  #9  
Old 09-26-2011, 11:27 AM
Senior Member
Garage is empty, add now
 
Join Date: Mar 1999
Location: N.E. Ohio
Vehicle: 2013 Ford F-150
Posts: 410
I had not had the burning odor from mine for a while now, probably since at least June or so, but this morning I had it for a short period of time.

I had hoped that it had resolved itself, but I guess not.
__________________

2013 F-150 Supercab 4x4 XLT, 5.0L, Ruby Red, Chrome Package, Ford Sportliner, Truxedo Lo-Pro, Bed Extender.
1989 F-150 Supercab 4x4 Longbed XLT Lariat, 5.8L/C-6 auto, Light Chestnut.
1979 F-350 Regular Cab 4x4 Custom, 460/C-6, Medium Vaquero/White.
Reply With Quote
Old 09-26-2011, 11:27 AM


 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



All times are GMT -4. The time now is 08:51 AM.


 
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company
Contact Us Advertising Privacy Statement Terms of Service Jobs Forum Text Archives
Emails & Contact Details

Search Engine Friendly URLs by vBSEO 3.5.2