Go Back   F150online Forums > F-Series Trucks > 2004 - 2008 F-150
Sign in using an external account
Register Forgot Password?
Register Photos Vin Decoder FAQ Members Search Today's Posts Mark Forums Read Vendor DirectoryGarage

2004 - 2008 F-150 SPONSORED BY:

Welcome to F150Online Forums!
Welcome to F150Online.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the F150Online Forums community today!





Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
  #1  
Old 03-02-2013, 12:05 AM
Senior Member
1999 Ford F-150
 
Join Date: Aug 2007
Vehicle: 1999 Ford F150
Posts: 373
Fuel pump fuse blowing....

My buddies 07 scab with 5.4 died today. Found the fuel pump fuse was blown and we replaced it. It started and ran for 10 or so seconds and died again with the same fuse blown. We checked any connections we could that ran to the fuel pump and there was no corrosion on any of them. Could the pump be plugged or going bad? It never ran poorly it just quit.
__________________

02 King Ranch with 7700 front suspension and bags, 4R100 and getting a 9.75 rear.
Navigator steering wheel and possibly front bumper.
Building my new motor and slapping in some forged goodies and an air pump.
Reply With Quote
  #2  
Old 03-02-2013, 12:25 AM
Senior Member
1999 Ford F-150
 
Join Date: Aug 2007
Vehicle: 1999 Ford F150
Posts: 373
Also no codes.
__________________

02 King Ranch with 7700 front suspension and bags, 4R100 and getting a 9.75 rear.
Navigator steering wheel and possibly front bumper.
Building my new motor and slapping in some forged goodies and an air pump.
Reply With Quote
  #3  
Old 03-02-2013, 04:35 AM
Senior Member
Garage is empty, add now
 
Join Date: Oct 2012
Vehicle: 2004 Ford F-150
Posts: 154
check the fuel pump driver module mounted above the spare tire on the cross member, they collect road salt and water and corrodes through the aluminum housing and kills the circuit board. the new one will come with stand off spacers to get the module off of the cross member. you will have to lower the spare tire to check it.
Reply With Quote
  #4  
Old 03-02-2013, 04:38 AM
Senior Member
Garage is empty, add now
 
Join Date: Oct 2012
Vehicle: 2004 Ford F-150
Posts: 154
http://www.f150online.com/forums/art...placement.html
Reply With Quote
  #5  
Old 03-02-2013, 04:44 AM
Senior Member
Garage is empty, add now
 
Join Date: Oct 2012
Vehicle: 2004 Ford F-150
Posts: 154
DORMAN Part # 590001 $57 on rockauto.com
Reply With Quote
  #6  
Old 03-02-2013, 03:05 PM
Senior Member
1999 Ford F-150
 
Join Date: Aug 2007
Vehicle: 1999 Ford F150
Posts: 373
I knew about the fpdm but I thought it would throw a code. Either way I will check into it! Thanx
__________________

02 King Ranch with 7700 front suspension and bags, 4R100 and getting a 9.75 rear.
Navigator steering wheel and possibly front bumper.
Building my new motor and slapping in some forged goodies and an air pump.
Reply With Quote
  #7  
Old 03-02-2013, 09:24 PM
Senior Member
Garage is empty, add now
 
Join Date: Oct 2012
Vehicle: 2004 Ford F-150
Posts: 154
it won't always throw a fault, could throw low fuel pressure faults, but if its blowing a fuse it may not set one.
Reply With Quote
  #8  
Old 03-04-2013, 05:11 PM
Senior Member
1999 Ford F-150
 
Join Date: Aug 2007
Vehicle: 1999 Ford F150
Posts: 373
well that was the problem thanx 04f150owner!
__________________

02 King Ranch with 7700 front suspension and bags, 4R100 and getting a 9.75 rear.
Navigator steering wheel and possibly front bumper.
Building my new motor and slapping in some forged goodies and an air pump.
Reply With Quote
  #9  
Old 03-05-2013, 02:48 AM
Senior Member
Garage is empty, add now
 
Join Date: Oct 2012
Vehicle: 2004 Ford F-150
Posts: 154
no problem, i found out about that issue from this site my self and replaced it before it could be an issue.
Reply With Quote
Old 03-05-2013, 02:48 AM


 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


All times are GMT -4. The time now is 10:10 PM.


 
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company
Contact Us Advertising Privacy Statement Terms of Service Jobs Forum Text Archives
Emails & Contact Details