Go Back   F150online Forums > F-Series Trucks > 2004 - 2008 F-150
Sign in using an external account
Register Forgot Password?
Register Photos Vin Decoder FAQ Members Search Today's Posts Mark Forums Read Vendor DirectoryGarage

2004 - 2008 F-150 SPONSORED BY:

Welcome to F150Online Forums!
Welcome to F150Online.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the F150Online Forums community today!





Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
  #1  
Old 10-14-2010, 08:46 AM
Member
Garage is empty, add now
 
Join Date: May 2010
Posts: 79
Backfire/popping when i get on gas.

Well its started a while ago but has became worse, when i return my truck to stock or the economy mode on my edge it will backfire/pop when i get on the gas or floor it. And not just once it does it pretty bad(almost like its insanely rich and its getting loaded up) but then clears out.

I'm not to sure on what it exactly could be. I have an edge evolution and when its on performance mode (3) it doesnt seem to do it.
two injectors and two coils have been recently replaced. My guess would be the rest of the coils...

Any suggestions would be greatly appreciated. thanks!

Last edited by Rebel-Offroad; 10-14-2010 at 09:01 AM.
Reply With Quote
  #2  
Old 10-14-2010, 01:06 PM
Senior Member
Garage is empty, add now
 
Join Date: Nov 2004
Location: Greenville, SC
Vehicle: 2004 Ford F150
Posts: 703
Any codes being thrown?
Reply With Quote
  #3  
Old 10-14-2010, 01:09 PM
Member
Garage is empty, add now
 
Join Date: May 2010
Posts: 79
no codes except a catylist code last week, cleared it and it hasnt came back on since
__________________
"Truck's a ford and the tractor's green"
-Out of a job yet?keep buying foreign
-Work harder, millions of illegals depend on you!

Reply With Quote
  #4  
Old 10-14-2010, 01:16 PM
Senior Member
Garage is empty, add now
 
Join Date: Nov 2004
Location: Greenville, SC
Vehicle: 2004 Ford F150
Posts: 703
Sounds like an injector is sticking open, if even for just a split second. Stick around. Someone smarter than me will likely chime in soon. I would start with coils, plugs, and maybe even all the injectors, too.

Good luck, man!
Reply With Quote
  #5  
Old 10-14-2010, 01:33 PM
Senior Member
1997 Ford F-150
 
Join Date: Sep 2009
Vehicle: 1997 Ford F-150
Posts: 107
Had the same problem and it ended up being plugs and wires
Reply With Quote
  #6  
Old 10-14-2010, 04:40 PM
Member
2010 Ford Freestar
My Garage
 
Join Date: Sep 2006
Location: Doylestown, Ohio
Vehicle: 2006 Ford F150
Posts: 90
Mine does the exact same thing. Its getting annoying, my truck has 72000mi guess its time to do the plugs and hope that fixes it.
Reply With Quote
  #7  
Old 10-14-2010, 05:25 PM
Technical Article Contributor
2005 Ford F-150
 
Join Date: Mar 2009
Location: Olive Branch, MS
Vehicle: 2005 Ford F150
Posts: 1,537
If it sounds like its coming from under your floor board then it's probably the cat. Mine did the exact same thing, popping at first acceleration shortly after it is started up and then it goes away if you let off the gas. Take it to the dealer and have them check it. They are under warranty till 80,000 if you are not over that yet.
__________________
2005 XLT 5.4 Screw 4x4
Scott
Reply With Quote
  #8  
Old 10-14-2010, 06:45 PM
Member
Garage is empty, add now
 
Join Date: May 2010
Location: Athens, TN
Vehicle: 2006 Ford F150
Posts: 59
i just replaced all 8 injectors, now i am guessing plugs and cops
Reply With Quote
Old 10-14-2010, 06:45 PM


 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


All times are GMT -4. The time now is 05:50 AM.


 
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company
Contact Us Advertising Privacy Statement Terms of Service Jobs Forum Text Archives
Emails & Contact Details