Go Back   F150online Forums > F-Series Trucks > 2004 - 2008 F-150
Sign in using an external account
Register Forgot Password?
Register Photos Vin Decoder FAQ Members Search Today's Posts Mark Forums Read Vendor DirectoryGarage

2004 - 2008 F-150 SPONSORED BY:

Welcome to F150Online Forums!
Welcome to F150Online.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the F150Online Forums community today!





Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
  #1  
Old 01-13-2009, 07:31 PM
Junior Member
Garage is empty, add now
 
Join Date: Jul 2008
Location: Toronto
Vehicle: 2008 Ford F150
Posts: 8
Gas Gauge Problem

Hello everyone!

Wow what a day.. Was out doing some small deliveries in my 08 F150 (got in july 08). Just small boxes I kept in the cab.

Anyways, I always check my gas gauge, and knew I had half tank left, halfway through my trip, I hear beep beep, look at my gas gauge and it's all the way at empty and even lower. Went to the station to put gas in, and still showed empty..

Now we just got a pretty big cold front coming through Toronto, but damn! killed my whole day.. now I'm driving a ford focus! not easy being 6'7! lol.


Anyways, just wondering if anyone has had this problem? I know my situation is kind of vague, but it feels great writing it out on here! lol.

Take care!
Erik-
Reply With Quote
  #2  
Old 01-13-2009, 08:09 PM
Senior Member
2010 Ford F-150
 
Join Date: Sep 2003
Location: Great Falls, Montana
Vehicle: 2010 Ford F-150
Posts: 561
Hopefully you're still in warranty. Sounds like they may have to drop the fuel tank and replace the sending unit and pump assembly. Hopefully, it's something simple.. I had a 2002 F-350 PS that did the same exact thing to me, under warranty, they replaced the pump/sending unit and took care of the problem. I had a feeling it was the sending unit so I went off road, drove it over some hills, bounced around alto and when I got level again, it was fine. Next day, poof, same problem.
Reply With Quote
  #3  
Old 01-14-2009, 10:07 AM
Junior Member
Garage is empty, add now
 
Join Date: Jul 2008
Location: Toronto
Vehicle: 2008 Ford F150
Posts: 8
Luckily it's still under warranty. So hopefully I go there whenever the truck is ready and not have to pay a cent lol.

Just such an inconvenience, cannot stand this Focus anymore lol..


Erik-
Reply With Quote
  #4  
Old 01-14-2009, 12:00 PM
Senior Member
2010 Ford F-150
 
Join Date: Nov 2006
Location: Temple, Tx
Vehicle: 2013 Ford F150
Posts: 465
Mine has a gas guage problem too, it lies to me. Itll tell me I have gone up to 275 miles on a half a tank of gas, causing me to get excited and think its doing great on gas. Then 50 miles later its on 1/4 of a tank.
Reply With Quote
  #5  
Old 02-10-2009, 02:11 PM
Junior Member
Garage is empty, add now
 
Join Date: Oct 2008
Location: Eagle River, AK
Vehicle: 2008 Ford F-150
Posts: 1
I've been having the same problem with my 08 as well. Ford replaced the sending unit last week. It was working fine until I filled up yesterday. Now it reads empty!

I called ford and they stated that this is common in the new vehicles. They said it's usually a chemical issue and recommend that I use fuel with techron or add a techron additive

Has anybody else been told this? Has it worked?
Reply With Quote
  #6  
Old 02-10-2009, 05:02 PM
Senior Member
Garage is empty, add now
 
Join Date: Nov 2008
Vehicle: 2008 Ford F150
Posts: 147
TSB 08-2-9
ERRATIC FUEL GAUGE OPERATION - MIL ON - DTCS P0460/P0463 OR INSTRUMENT CLUSTER MODULE DTC B1201 - VEHICLES BUILT BEFORE 12/3/2007

Publication Date: January 22, 2008
FORD: 2004-2008 F-150
LINCOLN: 2006-2008 Mark LT


ISSUE:
Some 2004-2008 F-150 and 2006-2008 Mark LT vehicles, built before 12/3/2007, may exhibit erratic fuel gauge operation or illuminated malfunction indicator lamp (MIL) with diagnostic trouble codes (DTCs) P0460 or P0463, and/or Instrument Cluster Module DTC B1201. This may be caused by sulphur contamination in the fuel causing an open or high resistance in the fuel level sender.

ACTION:
Follow the Service Procedure steps to correct the condition.

SERVICE PROCEDURE

Install a new fuel level sender following the service procedure instruction sheet provided in the fuel sender kit.

PART NUMBER PART NAME
8L3Z-9A213-E Kit - Fuel Sender (2006 starting 12/8/2005 through 2008 - FFV-26 Gal Tank - 126/132" WB )
8L3Z-9A213-F Kit - Fuel Sender (2006 starting 12/8/2005 through 2008 - FFV-30 Gal Tank - 139" WB)
8L3Z-9A213-G Kit - Fuel Sender (2006 starting 12/8/2005 through 2008 - FFV-27 Gal Tank - 145/151/163" WB
8L3Z-9A213-H Kit - Fuel Sender (2006 starting 12/8/2005 through 2008 - FFV-36 Gal Tank - 145/151/163" WB
8L3Z-9A213-A Kit - Fuel Sender (2004 through 2008 - Gas-26 Gal Tank - 126/132" WB
8L3Z-9A213-B Kit - Fuel Sender (2004 through 2008 - Gas-30 Gal Tank - 139" WB
8L3Z-9A213-C Kit - Fuel Sender (2004 through 2008 - Gas-27 Gal Tank - 145/151/163" WB
8L3Z-9A213-D Kit - Fuel Sender (2004 through 2008 - Gas-36 Gal Tank - 145/151/163"WB



WARRANTY STATUS:
Eligible Under Provisions Of New Vehicle Limited Warranty Coverage And Emissions Warranty Coverage
IMPORTANT: Warranty coverage limits/policies are not altered by a TSB. Warranty coverage limits are determined by the identified causal part.

OPERATION DESCRIPTION TIME
080209A 2004-2008 F-150, 2006-2008 Mark LT: Install New Fuel Level Sender, Includes Time To Remove And Install Fuel Tank (Do Not Use With 9002A, 9002A4, 9002A6) 1.9 Hrs.

DEALER CODING
BASIC PART NO. CONDITION CODE
9A299 42
Reply With Quote
  #7  
Old 02-10-2009, 08:58 PM
Senior Member
Garage is empty, add now
 
Join Date: Nov 2004
Location: Marquette MI
Vehicle: 2004 Ford F150 4X4
Posts: 121
When your tank really is low add a container of Techron gas addative - should fix the problem for about $7.00. I have the same problem with my 02 Vette and the Techron solution is a common and effective fix.
Reply With Quote
  #8  
Old 02-10-2009, 09:11 PM
Senior Member
Garage is empty, add now
 
Join Date: Feb 2009
Location: Cancun!
Vehicle: 2008 FoRd lObOF150
Posts: 464
Send a message via MSN to lObOdiablO
I notice an erratic revs gauge operation.. not a gas.. yet
Reply With Quote
  #9  
Old 02-11-2009, 12:42 AM
Senior Member
Garage is empty, add now
 
Join Date: Jul 2004
Location: Nashville, TN
Vehicle: 2008 Ford F250
Posts: 4,476
Mine is a diesel, but I had this same problem last week. I stopped, turned the truck off, turned it back on, and the issue went away. Weird!
Reply With Quote
  #10  
Old 02-26-2009, 10:10 PM
Technical Article Contributor
Garage is empty, add now
 
Join Date: Nov 2008
Location: Shawnee, KS
Vehicle: 2005 Ford F150
Posts: 409
I just noticed something like this tonight on my 05. I ran the tank pretty low so I could start using the 91 performance program on my Edge. Even when I filled the tank all the way up with 91, the guage still showed empty and the computer says I have 10 miles until empty. I wonder what happens when that hits 0. Looks like I'll need to run this in to the dealer.
__________________
2005 Supercrew Lariat 4x4 - Gone

Quote:
Originally Posted by Rockpick View Post
Having been around here for quite some time now, it's become VERY evident to me that some people just aren't happy unless they're thread crapping. It's really that simple.
Reply With Quote
  #11  
Old 02-22-2012, 09:54 AM
Member
1993 Ford Thunderbird
My Garage
 
Join Date: Jun 2008
Location: Roseville, MI
Vehicle: 2007 Ford F150
Posts: 48
www.facebook.com/acidsurfr www.twitter.com/acidsurfr
Send a message via AIM to acidsurfr Send a message via Yahoo to acidsurfr Send a message via Skype™ to acidsurfr
my '07 just started this as of this morning. Never had a problem in the past. Gas gauge showed "E" and low fuel on instrument panel. Stopped and filled up with the usual premium from Shell station by work. Got in and gas gauge barely raised above E. Contacted the dealer and they set up an appointment for next monday. Told me to cancel if it "self corrects" before then. Told them i only ever run premium from Shell or Speedway and she told me i am not suppose to run premium all of the time as the engine doesn't run hot enough to burn all of the deposits. Never heard of this, and what do engine deposits have to do with a tank or gauge issue. I am also running the Edge with canned tunes. usually run setting 3 for performance, but i have been running level 2 towing for about a month as i have been towing a drop deck trailer with a genie lift (about 7000 lb's) quite often for work lately. Any one else heard of the "premium" fuel all of the time as an issue, and the edge programming manual and everything i have read says NOT to run level 3 on anything but premium and to never run E85 with the programmer???
__________________
http://www.greatlakes4x4.com http://www.wegotmud.com

2007 FX4 SCrew, NCD leveling kit, Toyo M/T 33x12.5r18
AMSOIL Dry filter
Edge Evolution Programmer
Modified stock intake
Sirius Satellite
Reply With Quote
  #12  
Old 02-22-2012, 10:57 AM
Senior Member
2008 Ford F-150
 
Join Date: May 2005
Location: Broken Arrow, OK
Vehicle: 2008 Ford F150
Posts: 1,835
Quote:
Originally Posted by acidsurfr View Post
my '07 just started this as of this morning. Never had a problem in the past. Gas gauge showed "E" and low fuel on instrument panel. Stopped and filled up with the usual premium from Shell station by work. Got in and gas gauge barely raised above E. Contacted the dealer and they set up an appointment for next monday. Told me to cancel if it "self corrects" before then. Told them i only ever run premium from Shell or Speedway and she told me i am not suppose to run premium all of the time as the engine doesn't run hot enough to burn all of the deposits. Never heard of this, and what do engine deposits have to do with a tank or gauge issue. I am also running the Edge with canned tunes. usually run setting 3 for performance, but i have been running level 2 towing for about a month as i have been towing a drop deck trailer with a genie lift (about 7000 lb's) quite often for work lately. Any one else heard of the "premium" fuel all of the time as an issue, and the edge programming manual and everything i have read says NOT to run level 3 on anything but premium and to never run E85 with the programmer???
First of all, you are replying to a thread that has been dead for a few years, so it's probably better to start a new thread on the topic instead of waking it from the dead. Second, the Ford tech was right about never running premium fuel on a stock programmed vehicle as it is a waste of money. However, you mentioned you have an Edge programmer on Level 3, which is the premium fuel level, which requires you to so you're fine. Finally, the fuel gauge is known to hang up every now and then, it usually corrects itself after a few startups.
Reply With Quote
  #13  
Old 02-22-2012, 11:27 AM
glc glc is offline
Senior Member
Garage is empty, add now
 
Join Date: Dec 2006
Location: Joplin MO
Vehicle: 2003 Ford F150
Posts: 28,286
If you put gas in with the engine running, that will cause gas gauge issues.
__________________
2003 F-150 XL RCSB 2wd 4.2 M5OD 3.55 LS
Reply With Quote
  #14  
Old 02-23-2012, 09:05 AM
Member
1993 Ford Thunderbird
My Garage
 
Join Date: Jun 2008
Location: Roseville, MI
Vehicle: 2007 Ford F150
Posts: 48
www.facebook.com/acidsurfr www.twitter.com/acidsurfr
Send a message via AIM to acidsurfr Send a message via Yahoo to acidsurfr Send a message via Skype™ to acidsurfr
Sooner, thanks for the heads up...i simply did a search and found an existing one, my bad for not looking at the date. glc, the stations around here will shut your pump off if you are a) not standing outside of the vehicle b) vehicle is running hell they've even shut it off because the cashier inside saw me answer my cell phone while pumping gas. But thanks for the heads up guys. As an update, it slowly climbed up throughout the day yesterday and is now showing a full tank. Added a 20oz bottle of Techron to the tank to treat it anyhow.
__________________
http://www.greatlakes4x4.com http://www.wegotmud.com

2007 FX4 SCrew, NCD leveling kit, Toyo M/T 33x12.5r18
AMSOIL Dry filter
Edge Evolution Programmer
Modified stock intake
Sirius Satellite
Reply With Quote
Old 02-23-2012, 09:05 AM


 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


All times are GMT -4. The time now is 06:24 PM.


 
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company
Contact Us Advertising Privacy Statement Terms of Service Jobs Forum Text Archives
Emails & Contact Details