Go Back   F150online Forums > F-Series Trucks > 1997 - 2003 F-150
Sign in using an external account
Register Forgot Password?


1997 - 2003 F-150 SPONSORED BY:

Welcome to F150Online Forums!
Welcome to F150Online.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the F150Online Forums community today!





Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
  #1  
Old 07-03-2011, 12:50 AM
Junior Member
 
Join Date: Jul 2011
Posts: 1
Question Electric door locks not working

hi,
just got a 1999 F150 and the door locks only work with a key.
both switches do nothing like no power, fuse has power but the switches do nothing, no noise no click nothing on both driver and passenger side,
also the alarm seems to be not working but the fuse has power and not blown.
the blue light does not come on.
what would make both door locks not work with switch and the alarm not work?
i just got the truck so do not know history..
can anyone help?
i hate taking to a dealer unless i have an idea what is wrong and what the cost will be.

thanks
Reply With Quote
  #2  
Old 07-03-2011, 01:17 AM
Senior Member
 
Join Date: Oct 2009
Location: Corona, Crazyfornia
Vehicle: 2003 ford f150
Posts: 2,217
Power door locks too!

Look at this post. SSCULLY (A very smart guy) gave me some good sustem diagrams for the door locks.

My issue was a weak battery. But a few days later showed up in a bad driver side switch. If you search power window switch repair it is very simular.

Good luck.
__________________
Love my box stock V-6
Reply With Quote
  #3  
Old 07-03-2011, 01:17 AM
Senior Member
 
Join Date: May 2011
Posts: 215
I had the same problem and I had to replace both actuator for the locks and they work now
Reply With Quote
  #4  
Old 12-24-2013, 06:38 PM
Member
 
Join Date: Jan 2004
Location: LOCKNEY, TX
Vehicle: 1999 FORD F-150
Posts: 33
have the same problem with my '99, except the locks will click just sounds real weak and will not move door locks
Reply With Quote
  #5  
Old 12-24-2013, 10:41 PM
Senior Member
 
Join Date: Jun 2007
Location: Utah
Vehicle: 1999 Ford F-150 5.4
Posts: 5,133
The fail regular. Not all that easy to replace either.
__________________

1999 F-150 xlt 5.4 4x4
1971 Mach 351c 5 speed TKO600 Tremac-sold!
Reply With Quote
  #6  
Old 12-25-2013, 12:18 PM
Senior Member
 
Join Date: Jul 2002
Location: Lebanon, Missouri
Vehicle: 2000 Ford F150
Posts: 2,922
Mines been that way for years now, someday I'll get it fixed but it's not high on my to do list.
__________________
2000 F150 4x4 XLT 5.4L, 77 Series K&N, Gibson Super Sport Exhaust, Edge Evolution Programmer, Alpine DVD Player, 16x10 Chrome DC-1 Cepeks, 33" Nitto Terra Grapplers, Strobes, and on..
Videos of My Truck
http://www.youtube.com/user/ninerrulz
Reply With Quote
  #7  
Old 12-25-2013, 11:32 PM
Technical Article Contributor
 
Join Date: Oct 2005
Location: MI
Vehicle: 1998 Ford F150 5.4L 4X4
Posts: 25,594
Yea, mine aren't working now. I'll take them apart at some point. I believe something corrodes somewhere inside. Cleaning may solve the prob.
Reply With Quote
  #8  
Old 12-28-2013, 11:23 AM
JMC JMC is offline
Technical Article Contributor
 
Join Date: Dec 1997
Location: Windsor,Ontario,Canada
Vehicle: 2000 Ford F-150 4x4
Posts: 9,349
Send a message via ICQ to JMC
Disable the alarm and try the door locks.
__________________
Regards
Jean Marc Chartier


4.6 to 5.4 swap, M5OD w/ Hurst short throw, Warn XD9000i, OBX Long Tubes /w Cats, Troyer E-fans, P-1SC Procharger @15psi, Troyer tuned. ;)
Swap notes; http://www.f150online.com/forums/art...ml#post3570245
Reply With Quote
  #9  
Old 12-28-2013, 10:44 PM
Member
 
Join Date: Oct 2013
Posts: 17
My driver side was not working either when I bought it. The issue was that I heard grinding so the switch was working.

There is a DC brushed motor that has gears attached to the motor shaft...that move a long piece plastic with gears that is attached to the lock mechanism via a long rod....gears (plastics) had worn out on mine.

My solution was to just add a metal wedge in there as to make the worn gears make better contact...been working ever since I bought the truck..since I registered here.

I also fixed my brothers on his truck...his the problem was the DC brushes where gone...needed a new motor or the whole thing new...i just replaced the brushes.
Reply With Quote
Old 12-28-2013, 10:44 PM


 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


All times are GMT -4. The time now is 04:45 AM.


 
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company
Contact Us Advertising Privacy Statement Terms of Service Jobs Forum Text Archives
Emails & Contact Details